Bug 107965 - can't add printer uses Omni drivers
can't add printer uses Omni drivers
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-25 01:09 EDT by Dmitry Kamenka
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.0.2-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 16:16:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Kamenka 2003-10-25 01:09:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When I add a printer in redhat-config-printer that uses Omni drivers I get error 
"Cannot read file /usr/share/foomatic/db/source/driver/omni-xml.xml!
Driver file /usr/share/foomatic/db/source/driver/omni-xml.xml corrupted,
missing, or not readable!"

File /usr/share/foomatic/db/source/driver/omni-xml.xml doesn't exist.
It doesn't present in Omni or foomatic rpms.

Version-Release number of selected component (if applicable):
Omni-0.9.0-4 foomatic-3.0.0-8

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-printer
2. Try to add some printer uses Omni drivers
3. When you press the finish button you get the error on console


Actual Results:  I press finish button but printer isn't added
Comment 1 Tim Waugh 2003-10-25 08:30:33 EDT
Which printer do you add?
Comment 2 Dmitry Kamenka 2003-10-25 10:59:08 EDT
I add "Generic 9-pin 80 Col", "Generic 9-pin 136 Col" and get error. On other
Omni drivers I get the error too.

I get the following error:
Cannot read file /usr/share/foomatic/db/source/driver/omni-xml.xml!
Driver file /usr/share/foomatic/db/source/driver/omni-xml.xml corrupted,
missing, or not readable!
Traceback (most recent call last):
  File "/usr/share/printconf/util/addQueue.py", line 1238, in finish
    self.queue_data, driver_tuple)
  File "/usr/share/printconf/util/printconf_conf.py", line 968, in construct_queue
    printer.id, gs_driver)
  File "/usr/share/printconf/util/printconf_conf.py", line 807, in
foomatic_set_default_page_size
    for opt in drv.options.values():
AttributeError: 'NoneType' object has no attribute 'options'
Comment 3 Tim Waugh 2003-10-27 07:57:36 EST
Confirmed.
Comment 4 Tim Waugh 2003-10-27 09:19:24 EST
Should be fixed in foomatic-3.0.0-9.  Please verify that it fixes the problem
for you when it appears in rawhide in the next day or so.
Comment 5 Marius Andreiana 2005-08-19 16:16:12 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to "CURRENTRELEASE", however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thanks in advance.

PS: Omni drivers are no longer in FC4

Note You need to log in before you can comment on or make changes to this bug.