Bug 107999 - NFS filesystems don't mount on boot
NFS filesystems don't mount on boot
Status: CLOSED DUPLICATE of bug 97610
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 110253 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-25 19:45 EDT by Joshua Weage
Modified: 2014-03-16 22:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to /etc/init.d/netfs (initscripts) that waits for NFS servers to be available (862 bytes, patch)
2003-12-10 14:30 EST, Eric Eisenhart
no flags Details | Diff

  None (edit)
Description Joshua Weage 2003-10-25 19:45:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b)
Gecko/20030516 Mozilla Firebird/0.6

Description of problem:
I have just installed RedHat 9.0 on several machines with most of the updates as
of Oct. 25.  However, I did not update the initscripts rpm.  I'm running
kernel-2.4.20-20.9smp.

On boot, netfs fails with the following kernel error when attempting to mount
nfs filesystems:

RPC: Remote system error - No route to host

If I add 'mount -a' to /etc/rc.d/rc.local the filesystems are mounted properly.
 If I duplicate the line containing 'mount -a -t nfs' in /etc/init.d/netfs, the
first attempt fails and the second attempt works correctly.

If I remove netfs from the boot sequence, the NIS client setup fails, but when I
run '/etc/init.d/ypbind restart' after boot, it works fine.

It appears that the first service that attempts to use rpc fails.  I've seen
similar problems on RedHat 7.3.

This most likely has nothing to do with initscripts, but I'm not sure where the
problem is coming from.



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Install Red Hat 9.0
2. Put NFS filesystems in /etc/fstab
3. Reboot
    

Actual Results:  NFS filesystems are not mounted on boot.

Expected Results:  NFS filesystems mounted on boot.

Additional info:
Comment 1 Eric Eisenhart 2003-12-10 14:30:18 EST
Created attachment 96453 [details]
patch to /etc/init.d/netfs (initscripts) that waits for NFS servers to be available

We've encountered a similar problem on RedHat 7.3 servers with
initscripts-6.67-1.  netfs fails to mount during bootup, but will succeed
later.	We don't have any NIS.

The problem appears to be that the network driver modules reset the ethernet
cards during the "network" phase of bootup and the network doesn't fully
function until some time afterward.  The time from "service network start"
(module loading) until full operation may be longer due to these machines
havine 3 ethernet interfaces.

I haven't checked, but I'm assuming that when the network card isn't fully
"on", the mount attempts get a "network unreachable" error instead of a "host
unreachable" and therefore don't retry as they normally would if the host was
merely unreachable.

Our fix has been to add a piece to the top of /etc/init.d/netfs that tries to
ping its NFS servers for a while before mounting.  It's written such that
successful pinging will go past that step in a second or two and unsuccessful
pinging will wait up to 5 minutes before proceeding.  The long wait is
acceptable in our case, since the servers can't accomplish their intended tasks
without access to the NFS server.  A superior fix might be to have
/etc/init.d/network try a similar pinging routine on its own IPs for up to 30
seconds per interface.

I'm attaching the modified network script.  The ping loops are to avoid any
possible problems with ping binding to the wrong network interface due to the
correct interface not being available yet.
Comment 2 Bill Nottingham 2003-12-10 15:09:12 EST
*** Bug 110253 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2003-12-10 15:17:24 EST

*** This bug has been marked as a duplicate of 97610 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:59:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.