Bug 108002 - SMP ACPI does not config SATA interrupts right on i875P
Summary: SMP ACPI does not config SATA interrupts right on i875P
Status: CLOSED DUPLICATE of bug 108001
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-26 01:00 UTC by Jon Smirl
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Smirl 2003-10-26 01:00:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031023

Description of problem:
I have SCSI and the ICH5 SATA drivers built into my kernel. Uniprocessor this
works fine. The OS install kernel also works. 

The default SMP kernel does not work. Same for a custom one I have built trying
to select all the appropriate options. The SATA driver comes up and assigns the
SATA drive IRQ 17. When the partition is probed I get DMA timeouts. I am pretty
certain that there is some problem with ACPI getting IRQ 17 configured
correctly. I can't capture the dmesg since it won't boot.

2.6-test9 works without problem smp and uni. 2.6 requires full ACPI support for
SATA to work in SMP mode. I am using SCSI ATA support in test9 too.

Machine is Dell PE400SC with one SATA and one IDE drive. Hyperthreaded CPU used
for SMP mode. i875P, P4 2.8C. ICH5 no hardware RAID.

See this bug for lots of ACPI info about my machine:
http://bugzilla.kernel.org/show_bug.cgi?id=1173

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2108.nptl

How reproducible:
Always

Steps to Reproduce:
Boot machine with SMP kernel
    

Additional info:

Comment 1 Jon Smirl 2003-10-26 01:02:34 UTC

*** This bug has been marked as a duplicate of 108001 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:59:25 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.