Bug 108055 - redhat-config-bind fails to start up
Summary: redhat-config-bind fails to start up
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-bind
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
: 1081387 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-27 07:41 UTC by Ulrich Drepper
Modified: 2014-03-27 11:43 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2003-11-06 04:28:06 UTC


Attachments (Terms of Use)

Description Ulrich Drepper 2003-10-27 07:41:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031021
Firebird/0.7+

Description of problem:
I never used r-c-b before, my named.conf file is created by hand and is highly
customized.  It is well-formed as attested by named starting up and not
complaining.  But r-c-b fails with

Traceback (most recent call last):
  File "/usr/sbin/redhat-config-bind-gui", line 93, in ?
    cfg = ConfNamed.ConfNamed("/etc/named.conf",ROOTDIR)
  File "/usr/share/redhat-config-bind/ConfNamed.py", line 318, in __init__
    current[-1].setOpt(val[0],join(val[1:],' '))
IndexError: list index out of range


Version-Release number of selected component (if applicable):
redhat-config-bind-2.0.0-18

How reproducible:
Always

Steps to Reproduce:
0.I'll try to attach a sanitized version of my named.conf file.
1.use said file
2.start r.c.b
    

Actual Results:  message above

Expected Results:  dialog of r-c-b

Additional info:

Comment 2 Daniel Walsh 2003-11-06 04:28:06 UTC
New and improved version built.  2.0.1-1

Try it out.



Comment 3 Ulrich Drepper 2003-11-06 04:44:22 UTC
Indeed, it starts up.  There are some warnings and some missing
functionality.  I'll file separate bugs for those issues.

Comment 4 dongpj 2014-03-27 11:43:50 UTC
*** Bug 1081387 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.