Bug 108064 - rpmdb corrupt-tried fix at www.rpm.org/repairdb/, still get seg fault
Summary: rpmdb corrupt-tried fix at www.rpm.org/repairdb/, still get seg fault
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 9
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
: 108123 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-27 10:53 UTC by keith roberts
Modified: 2007-04-18 16:58 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-09-26 21:46:59 UTC


Attachments (Terms of Use)

Description keith roberts 2003-10-27 10:53:45 UTC
Description of problem: corrupt rpm database


Version-Release number of selected component (if applicable):
rpm-4.2.1-0.30

I did everything that it said to do at http://www.rpm.org/hintskinks/repairdb/
ending with 'rpm -qa'. I still get 'segmentation fault'

these are the faults:
error: rpmdbNextIterator: skipping h#     109 blob size(3772): BAD, 8 + 16 *
il(17) + dl(3460)
error: rpmdbNextIterator: skipping h#     304 blob size(2268): BAD, 8 + 16 *
il(17) + dl(1956)
error: rpmdbNextIterator: skipping h#     650 Header V3 DSA signature: BAD, key
ID db42a60e
error: rpmdbNextIterator: skipping h#     651 Header V3 DSA signature: BAD, key
ID 66534c2b
error: rpmdbNextIterator: skipping h#     652 Header V3 DSA signature: BAD, key
ID e42d547b
error: rpmdbNextIterator: skipping h#     653 Header V3 DSA signature: BAD, key
ID b8693f2c

These seem to to be all of them, some of them more than once.

Comment 1 Matthew Wire 2003-10-29 00:35:56 UTC
I have exactly the same problem, and have also tried everything described on
repairdb with no success

Comment 2 Roy Stogner 2003-11-05 16:19:53 UTC
I've also got this problem.  Using the "--nosignature" option for RPM
sometimes lets a transaction complete, but not reliably, and I see
deadlocks as well as segfaults.

I think I have a recent backup of my rpm database from before it
became corrupt - if that turns out to be the case and having some
"before and after" data would help with debugging, let me know and
I'll provide both databases for download.  I'm seeing these errors
with a 4.2.1 rpm from rawhide now, but I first experienced them with
an rpm 4.2 build from http://atrpms.physik.fu-berlin.de/

Comment 3 Jeff Johnson 2003-12-27 20:51:29 UTC
One person per bug please, or I will go bonkers ;-)

phaedrus: Can you try
    rm -f /var/lib/rpm/__db*
    rm -f /var/lib/rpm/Pubkeys
    rpm -qa
    rpm --rebuilddb -vv
    rpm -qa

Comment 4 Leonard den Ottolander 2004-03-10 17:05:01 UTC
Bug 108123 appears to be a duplicate of this one.


Comment 5 Adam Szalkowski 2004-04-02 17:25:24 UTC
*** Bug 108123 has been marked as a duplicate of this bug. ***

Comment 6 David Gore 2004-10-06 18:53:42 UTC
I am also having difficulty with my rpm database.  After performing
the requested

rm -rf /var/lib/rpm/__db*
rpm --rebuilddb -vv

Everything seems to run ok for a little while before I get:

D:  read h#     221 Header V3 DSA signature: NOKEY, key ID db42a60e
D:   +++ h#     546 Header V3 DSA signature: NOKEY, key ID db42a60e
D: adding "tetex-afm" to Name index.
D: adding 309 entries to Basenames index.
Segmentation fault

Any ideas?

-Dave

RH9 Linux 2.4.20-31.9 #1 Tue Apr 13 17:38:16 EDT 2004 i686 athlon i386

Comment 7 David Gore 2004-10-06 19:18:39 UTC
I should add that I have rpm-4.2-1

-Dave

Comment 8 David Gore 2004-10-10 02:52:01 UTC
Ok, problem solved:  my motherboard fried (capacitors turn a nice
shade of turquoise).  Upgraded PS, MB, CPU, RAM, and OS (FC2). 

Not the way I would have preferred to handle it.... :(

-Dave

Comment 9 Paul Nasrat 2005-09-26 21:46:59 UTC
Initial bug likely to be dangling pointer (bug #107835)

Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.



Note You need to log in before you can comment on or make changes to this bug.