Bug 108123 - rpm segfaulting when trying to repair rpmdb
rpm segfaulting when trying to repair rpmdb
Status: CLOSED DUPLICATE of bug 108064
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
http://www.rpm.org/hintskinks/repairdb/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 14:59 EST by Adam Szalkowski
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Szalkowski 2003-10-27 14:59:15 EST
Description of problem:
I just visited http://www.rpm.org/hintskinks/repairdb/ and tried to follow the
instructions to repair my corrupted /var/lib/rpm/Packages.
"rpmdb_dump Packages-OLD | rpmdb_load Packages" gave no errors, but rpm -qa
still showed the same errors (about 100x "error: rpmdbNextIterator: skipping h#
   1876 Header V3 DSA signature: BAD, key ID e42d547b") and segfaulted in the end.

Version-Release number of selected component (if applicable):
4.2

How reproducible:
always?

Steps to Reproduce:
1. rpm -qa or --rebuilddb or whatever!
    
Actual results:
100x "error: rpmdbNextIterator: skipping h#    1876 Header V3 DSA signature:
BAD, key ID e42d547b"

Expected results:


Additional info:
Comment 1 Jeff Johnson 2003-10-30 07:43:49 EST
Hmmm, if you have 100 headers damaged, then you
might want to reinstall, that's a lot of headers
to try to replace.

Can you attach output of
    rpm --rebuilddb -vv --nodigest --nosignature
so that I can try to assess what's borked?
Comment 2 Leonard den Ottolander 2004-03-10 12:04:17 EST
This seems to be a duplicate of bug 108064. Not sure if you want to
close this one as such, or whether you are still expecting the
requested log.
Comment 3 Adam Szalkowski 2004-04-02 12:25:21 EST

*** This bug has been marked as a duplicate of 108064 ***
Comment 4 Leonard den Ottolander 2004-04-02 12:57:35 EST
Adam, can you still submit the requested log, or did you already
reinstall? No backups?
Comment 5 Adam Szalkowski 2004-04-02 13:14:37 EST
sorry, I already reinstalled a few months ago (forgot about this
thread). There seem to be no backups left.
The db got probably corrupted because I have had a broken ram module
installed. But even without that module rpm segfaulted when trying to
rebuild the db.
If I ever get the same error again (now using fedora core 1) I'll try
to be a little bit more patient trying to fix it...
Comment 6 Red Hat Bugzilla 2006-02-21 13:59:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.