Bug 1080832 - libjpeg-turbo-1.3.1 is available
Summary: libjpeg-turbo-1.3.1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libjpeg-turbo
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1087908 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-26 08:33 UTC by Upstream Release Monitoring
Modified: 2014-05-08 10:04 UTC (History)
3 users (show)

Fixed In Version: libjpeg-turbo-1.3.1-2.fc19
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-17 08:35:13 UTC


Attachments (Terms of Use)
Add missing header file to install command (537 bytes, patch)
2014-04-16 07:18 UTC, Simone Caronni
no flags Details | Diff
Cleaned up SPEC file for 1.3.1 (7.55 KB, text/plain)
2014-04-16 07:19 UTC, Simone Caronni
no flags Details

Description Upstream Release Monitoring 2014-03-26 08:33:58 UTC
Latest upstream release: 1.3.1
Current version/release in Fedora Rawhide: 1.3.0-2.fc21
URL: http://sourceforge.net/api/file/index/project-name/libjpeg-turbo/mtime/desc/limit/200/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Petr Hracek 2014-04-16 06:56:15 UTC
*** Bug 1087908 has been marked as a duplicate of this bug. ***

Comment 2 Simone Caronni 2014-04-16 07:17:43 UTC
According to http://www.libjpeg-turbo.org/Documentation/Documentation there have been no API/ABI changes between 1.2 and 1.3. Since Fedora 19 is at 1.2.90 I see no problem in upgrading, but please proceed as you redeem safe.

Tests here on Fedora 20 with various packages do not show any problems. I'm reattaching the patch here for enabling the missing header (should also be applied to f19/f20 branches).

A couple of things on the spec file:

1) All of the RHEL 5 style directives can be removed, that is:

Group:

%files
%defattr(-,root,root,-)

%install
rm -rf $RPM_BUILD_ROOT

2) The obsolency of libjpeg < 6b-47 can also probably be removed, as those packages were last available in Fedora 12.

3) Static libraries can probably be removed, as they should not be packaged, that is adding the following to libjpeg-turbo-devel:

Obsoletes:     libjpeg-turbo-static < 1.3.1
Provides:      libjpeg-turbo-static = 1.3.1%{?dist}

And adding "--disable-static" to the %configure command.

I've applied myself for commit, if you grant commit access I will not update the older f19/f20 branches with 1.3.1 if you don't want. In that case I will only remove the obsolete SPEC tags, static libraries and add the missing header.

Attaching the updated SPEC file as well, suitable for at least the devel branch.

Thanks & regards,
--Simone

Comment 3 Simone Caronni 2014-04-16 07:18:36 UTC
Created attachment 886766 [details]
Add missing header file to install command

Comment 4 Simone Caronni 2014-04-16 07:19:13 UTC
Created attachment 886767 [details]
Cleaned up SPEC file for 1.3.1

Comment 5 Petr Hracek 2014-04-16 07:25:11 UTC
I have no problem with that.
in rawhide I have already prepared new upstream version.
Some testing is ongoing.

However thank you for interest and support.

Comment 6 Petr Hracek 2014-04-16 10:44:50 UTC
I have compared both versions as libjpeg-turbo-1.3.0 as libjpeg-turbo-1.3.1 and soname bump wasn't really changed.

In the patch is mentioned to add jpegint.h to devel package.
There are a bit more header files who could be included in devel package too.

List of headers:
-rw-r--r-- 1 phracek phracek  1856 Aug 12  2013 bmp.h
-rw-r--r-- 1 phracek phracek  5331 Oct 10  2010 cderror.h
-rw-r--r-- 1 phracek phracek  6256 Oct 10  2010 cdjpeg.h
-rw-r--r-- 1 phracek phracek  1575 May 25  2006 jchuff.h
-rw-r--r-- 1 phracek phracek  9626 Jan 28  2012 jdct.h
-rw-r--r-- 1 phracek phracek  9189 Dec 31  2012 jdhuff.h
-rw-r--r-- 1 phracek phracek 14748 Jun 21  2011 jerror.h
-rw-r--r-- 1 phracek phracek  3250 May 25  2006 jinclude.h
-rw-r--r-- 1 phracek phracek  8238 Feb 27  2010 jmemsys.h
-rw-r--r-- 1 phracek phracek 13823 Jan  6  2013 jmorecfg.h
-rw-r--r-- 1 phracek phracek  1054 Jan 28  2012 jpegcomp.h
-rw-r--r-- 1 phracek phracek 16090 Mar 29  2011 jpegint.h
-rw-r--r-- 1 phracek phracek 50298 Jan 19  2013 jpeglib.h
-rw-r--r-- 1 phracek phracek  4587 Feb  2  2011 jsimddct.h
-rw-r--r-- 1 phracek phracek  4119 Feb 18  2011 jsimd.h
-rw-r--r-- 1 phracek phracek   847 Feb 11 10:56 jversion.h
-rw-r--r-- 1 phracek phracek  1948 May 24  2011 tjutil.h
-rw-r--r-- 1 phracek phracek  9768 Jan  1  2013 transupp.h
-rw-r--r-- 1 phracek phracek 37558 Mar 11 10:46 turbojpeg.h

Comment 7 Simone Caronni 2014-04-16 11:28:08 UTC
(In reply to Petr Hracek from comment #6)
> In the patch is mentioned to add jpegint.h to devel package.
> There are a bit more header files who could be included in devel package too.

Sure, no problem. I added jpegint.h only as it was the only one that prevented a package to built with the library.

Comment 8 Account closed by the user 2014-04-16 13:29:30 UTC
(In reply to Simone Caronni from comment #2)

> According to http://www.libjpeg-turbo.org/Documentation/Documentation there
> have been no API/ABI changes between 1.2 and 1.3.

API changes/compatibility report for the libjpeg-turbo library:
http://upstream-tracker.org/versions/libjpeg-turbo.html

Comment 9 Simone Caronni 2014-04-16 13:37:18 UTC
(In reply to Xose Vazquez Perez from comment #8)
> API changes/compatibility report for the libjpeg-turbo library:
> http://upstream-tracker.org/versions/libjpeg-turbo.html

Cool! I didn't know about that website. It seems it's a safe upgrade to 1.3.1 for all branches; including 1.2.90 (f19).

Comment 10 Simone Caronni 2014-04-17 08:26:40 UTC
I just discovered that libjpeg is (wrongly) still a requirement for some packages:

$ sudo repoquery --whatrequires libjpeg
darkplaces-0:20130605-2.fc20.x86_64
java-1.7.0-openjdk-headless-1:1.7.0.60-2.4.3.0.fc20.x86_64
java-1.7.0-openjdk-headless-1:1.7.0.60-2.4.5.1.fc20.x86_64

For now please push the update only to f21 without the libjpeg provides/obsoletes; we can then send a notification on the devel list to fix those three builds. This should have been fixed in Fedora 13, then the libjpeg-turbo feature was announced.

I will open a bug on those components.

Comment 11 Petr Hracek 2014-04-17 08:35:13 UTC
New upstream version is in rawhide by commit (https://lists.fedoraproject.org/pipermail/scm-commits/Week-of-Mon-20140414/1226356.html)

Other Fedora versions will be updated soon.

Comment 12 Petr Hracek 2014-04-17 08:38:20 UTC
I have pushed the changes to rawhide anyway:(
Including provides/obsoletes.

Please send a bug to those components and I will revert changes regarding
Provides/Obsoletes in rawhide.

Comment 13 Simone Caronni 2014-04-17 08:46:21 UTC
(In reply to Petr Hracek from comment #12)
> I have pushed the changes to rawhide anyway:(
> Including provides/obsoletes.
> 
> Please send a bug to those components and I will revert changes regarding
> Provides/Obsoletes in rawhide.

I've already re-added libjpeg-devel Provides/Obsoletes in rawhide and cleaned up the spec file. (version 1.3.1-2).

I will make also tab/spaces consistent all over the spec file in the next commit.

Comment 14 Simone Caronni 2014-04-17 08:52:58 UTC
$ rpmlint libjpeg-turbo.spec 
0 packages and 1 specfiles checked; 0 errors, 0 warnings.

Fedora 21 build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6748753

Comment 15 Simone Caronni 2014-04-17 08:54:16 UTC
Erm... the change from "RAWHIDE" to "NOTABUG" is due to the trackpad.

Comment 16 Petr Hracek 2014-04-17 09:08:26 UTC
I think that we are ready to merge changes into F20, F19.

I will do that soon.

Comment 18 Fedora Update System 2014-04-17 13:07:45 UTC
libjpeg-turbo-1.3.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libjpeg-turbo-1.3.1-2.fc20

Comment 20 Fedora Update System 2014-04-17 13:47:43 UTC
libjpeg-turbo-1.3.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libjpeg-turbo-1.3.1-2.fc19

Comment 21 Fedora Update System 2014-04-20 01:27:59 UTC
libjpeg-turbo-1.3.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2014-05-08 10:04:53 UTC
libjpeg-turbo-1.3.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.