Bug 1087908 - Missing header file in package
Summary: Missing header file in package
Keywords:
Status: CLOSED DUPLICATE of bug 1080832
Alias: None
Product: Fedora
Classification: Fedora
Component: libjpeg-turbo
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-15 14:44 UTC by Simone Caronni
Modified: 2014-04-16 07:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-16 06:56:15 UTC


Attachments (Terms of Use)
Add missing header file to install command (537 bytes, patch)
2014-04-15 16:40 UTC, Simone Caronni
no flags Details | Diff

Description Simone Caronni 2014-04-15 14:44:44 UTC
Current libjpeg-turbo package is missing the header file "jpconfig.h" which is referenced by jpeglib.h. The header is included in the upstream tarball.

This makes impossible to compile programs linking the library, so it should be added to the libjpeg-turbo-devel package.

Also, the package could probably be udpated in f19, f20 and f21 to version 1.3.1, as according to release notes it should be binary compatible with 1.2.90 and 1.3.1.

I can offer myself as co-maintainer of the package.

Comment 1 Simone Caronni 2014-04-15 16:22:44 UTC
(In reply to Simone Caronni from comment #0)
> Current libjpeg-turbo package is missing the header file "jpconfig.h" which
> is referenced by jpeglib.h. The header is included in the upstream tarball.

Pardon, the missing file referenced by jpeglib.h is not jpconfig.h but "jpegint.h".

Comment 2 Simone Caronni 2014-04-15 16:40:51 UTC
Created attachment 886552 [details]
Add missing header file to install command

Comment 3 Petr Hracek 2014-04-16 06:56:15 UTC
Hi Simone,

I will check whether soname bump was changed.
But do you think that it is a good idea to rebase package also in older versions then only in rawhide?

I will add header files to package.
In rawhide it is libjpeg-turbo package in version 1.3.0

Hmm, for this issues it would be good to have a rebase helper who will show user what header files are missing in package.

*** This bug has been marked as a duplicate of bug 1080832 ***

Comment 4 Simone Caronni 2014-04-16 07:07:42 UTC
Thanks, will reply in #1080832.


Note You need to log in before you can comment on or make changes to this bug.