Bug 108093 - ICQ requires patch to prevent crashing
Summary: ICQ requires patch to prevent crashing
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL: http://sourceforge.net/forum/forum.ph...
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-27 17:02 UTC by Ed Marshall
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-02 21:53:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Marshall 2003-10-27 17:02:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Firebird/0.7

Description of problem:
When connecting to an ICQ account with Gaim, the entire client will crash. Known
problem, the thread for the discussion is here, along with a full traceback that
I posted:

http://sourceforge.net/forum/forum.php?thread_id=958196&forum_id=665

A patch for the crash is here:

http://gaim.sf.net/oscar-icq-utf8-hack.diff

Version-Release number of selected component (if applicable):
gaim-0.71-2

How reproducible:
Always

Steps to Reproduce:
1. Start Gaim.
2. Log into an ICQ account.
3. Boom. ;-)
    

Actual Results:  Segfault.

Expected Results:  Lots of spam from people I don't know on ICQ. ;-)

Additional info:

Acknowledged and fixed in Gaim CVS. It'd REALLY be nice to get this in before FC
pushes a release out, since Gaim is useless for ICQ users without this patch.
I've tested this as an additional patch against Fedora's 0.72-2, and it works
like a champ.

Comment 1 Christopher Blizzard 2003-12-02 21:53:36 UTC
gaim 0.74-5 is in the pipe which includes this fix.


Note You need to log in before you can comment on or make changes to this bug.