Bug 108094 - (TBdc373409) TB GUI_functions.py:541:gui_run_dialog:AttributeError:'NoneType' object has no attribute 'set_from_stock'
TB GUI_functions.py:541:gui_run_dialog:AttributeError:'NoneType' object has n...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
: 117282 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 12:06 EST by Scott Otterson
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.3.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 08:50:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Otterson 2003-10-27 12:06:21 EST
After using neat to add a wireless network card, I got a crash popup with the
suggestion that I send the crash info I've pasted below the dotted line.  The
wireless card doesn't work after configuration and, after the crash, my ethernet
and dialup connections are broken.  

help

-----------------------------------------------------------------------------

Component: redhat-config-network
Version: 1.2.15
Summary: TBdc373409 GUI_functions.py:541:gui_run_dialog:AttributeError:
'NoneType' object has no attribute 'set_from_stock'
Traceback (most recent call last):
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 799, in on_deviceActivateButton_clicked
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDevice.py",
line 376, in activate
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/NC_functions.py",
line 420, in generic_run_dialog
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/GUI_functions.py",
line 541, in gui_run_dialog
AttributeError: 'NoneType' object has no attribute 'set_from_stock'

Local variables in innermost frame:
status: -1
fdin: []
swindow: <gtk.ScrolledWindow object (GtkScrolledWindow) at 0x86e9a54>
string: <module 'string' from '/usr/lib/python2.2/string.pyc'>
okbutton: <gtk.Button object (GtkButton) at 0x8762924>
buffer: <gtk.TextBuffer object (GtkTextBuffer) at 0x876656c>
cancelbutton: <gtk.Button object (GtkButton) at 0x87628dc>
pid: 1493
command: /usr/sbin/usernetctl
argv: ['/usr/sbin/usernetctl', 'ppp1', 'up']
searchPath: 0
label: Activating network device ATT, please wait...
lbl: <gtk.Label object (GtkLabel) at 0x87611ac>
select: <module 'select' from '/usr/lib/python2.2/lib-dynload/selectmodule.so'>
stdin: 0
xml: <gtk.glade.XML object (GladeXML) at 0x8764ec4>
catchfd: (1, 2)
fderr: []
dlg: <gtk.Dialog object (GtkDialog) at 0x876a93c>
errlabel: Cannot activate network device ATT!

fdout: []
root: /
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
CancelException: netconfpkg.gui.GUI_functions.CancelException
mark: <gtk.TextMark object (GtkTextMark) at 0x872f0d4>
write: 16
read: 15
s: 1
childpid: 1493
closefd: -1
dialog: <gnome.ui.App object (GnomeApp) at 0x85fa2ac>
rc: 
title: redhat-config-network:

Network device activating...
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
textview: <gtk.TextView object (GtkTextView) at 0x8748694>
Comment 1 Harald Hoyer 2004-03-02 11:37:45 EST
*** Bug 117282 has been marked as a duplicate of this bug. ***
Comment 2 Harald Hoyer 2004-03-02 11:38:25 EST
very strange...

Note You need to log in before you can comment on or make changes to this bug.