Bug 108139 - gpm consistently fails during shutdown
gpm consistently fails during shutdown
Status: CLOSED DUPLICATE of bug 109613
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
: 109440 (view as bug list)
Depends On:
Blocks: 1092056
  Show dependency treegraph
 
Reported: 2003-10-27 17:47 EST by Gene Czarcinski
Modified: 2014-04-29 10:08 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-10-27 17:47:44 EST
Description of problem:

During bootup, gpm seems to start OK (no error messages).  However, during
shutdown, I consistently get:


Shutting down console mouse services:                      [FAILED]
Comment 1 Gene Czarcinski 2003-10-27 17:55:08 EST
I just looked in /var/log/messages and found that although the service start
message said "OK", there was a startup failure:

Oct 27 11:01:15 moscow gpm: gpm startup succeeded
Oct 27 11:01:27 moscow gpm[5794]: O0o.oops(): [gpm.c(949)]:
Oct 27 11:01:27 moscow gpm[5794]: mouse initialization failed

The shutdown is failing because gpm is not running.
Comment 2 Bill Nottingham 2003-10-27 22:37:22 EST
Are you booting with rhgb?
Comment 3 Gene Czarcinski 2003-10-28 04:28:56 EST
Yes, bootup with rhgb
Comment 4 Bill Nottingham 2003-10-28 10:58:53 EST
gpm very well may fail to start while X is running for rhgb - it won't be able
to open the mouse.
Comment 5 Jonathan Blandford 2003-10-28 13:19:12 EST
Do console mouse services work at all?
Comment 6 Don Hardaway 2003-11-11 10:43:24 EST
I am having the same problem on my dell c800 laptop. When I F1 to a
console there is no mouse. When I shutdown i get the same error
reported above.
Comment 7 Eido Inoue 2003-11-13 15:33:09 EST
*** Bug 109440 has been marked as a duplicate of this bug. ***
Comment 8 mark 2003-12-04 03:11:17 EST
I'm not sure my problem is exactly the same, but it definitely occures
on shutdown on gpm (Fedora Core 1). 

If gpm is allowed, after rebooting or shutting down the PS/2 mouse
can't be detected (kudzu removes it from hw conf). Everything is then
blocked (both mouse and keyboard). After resetting the computer, kudzu
finds the mouse again and this time it works. It looks like gpm or
related scripts are not shutting down cleanly.

If I disable gpm, everything works OK. 

I have disabled rhgb, and even switched to runlevel 3, so that X is
not involved at all.

Still, if I'm using "reboot" or "poweroff" (that is services are
shutted down), next time my mouse is not detected. If I reset or power
off the computer (without allowing gpm to go through shutdown), mouse
is detected normally. 
Comment 9 David G. Mackay 2004-01-24 20:26:33 EST
I just upgraded from RH9 to Fedora Core 1, and I experienced the
problem after the upgrade.  If I switch to a text console, and do a
service gpm start, gpm starts OK.  I can then use it to cut and paste
between text consoles.  GPM dies immediately, however, when I switch
to the X console.
Comment 10 Marc Williams 2004-02-14 11:01:58 EST
In my case, I getthe exact same errors as mentioned above (when
starting up or shutting down) if I use my PS/2 converter.  If I don't
use the converter and just plug my mouse (generic wheel mouse)
directly into a USB port, no more errors.
Comment 11 Eido Inoue 2004-02-20 15:28:04 EST

*** This bug has been marked as a duplicate of 115870 ***
Comment 12 Eido Inoue 2004-02-20 15:30:39 EST
bah. typed in the wrong number for the duplicate. This bug goes into
the "gpm doesn't like to compete for the mouse with X unless USB" category

*** This bug has been marked as a duplicate of 109613 ***
Comment 13 Red Hat Bugzilla 2006-02-21 13:59:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.