Bug 10814 - buggy man pages
buggy man pages
Status: CLOSED DUPLICATE of bug 19555
Product: Red Hat Linux
Classification: Retired
Component: groff (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-14 07:31 EDT by Michael Redinger
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-02 20:00:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-04-14 07:31:03 EDT
There's a file called :.1.gz in /usr/man (being part of the bash2 package).
However, if you try something like this on that file:

zcat :.1.gz |nroff -man

You get an error:

realpath on `man1/builtins2.1' failed: No such file or directory

This is because this file is now called builtins2.1.gz (as all man pages
are compressed now). This is caused by the following line in :.1.gz:

.so man1/builtins2.1

so, probably unzip builtins2 or make : a link to that file ...


This posting goes to you as your package was one of the first ones I found
... a quick check (which might be wrong, but I found that it was always
true for those files I examined manually) showed 750 buggy files.

I used a simple script that I did execute in every directory (there might
be more simple methods, but it happened that I needed something like this
by accident):

for i in *.gz ; do
   zcat $i | man2html 2>/dev/null | \
   grep "^<H1>.*</H1>$"
done | grep "Invalid Manpage" | wc -l

COULD SOMEBODY CHECK THIS???

I think this is a _very_ bad thing. The bug is not big enough to update
every single package, but if you sum this up, it's quite a big mistake ...
(anyway, there are some packages - like bash2 - where this .so syntax is
used in quite a few files. So, maybe change those ...
Comment 1 Denice 2000-05-17 05:05:59 EDT
There is also a file called  ..1.gz in /usr/man/man1 which also comes
from bash2-2.03-8:

  $ cd /usr/man/man1
  $ gunzip -c ..1.gz
  .so man1/builtins2.1
Comment 2 Bernhard Rosenkraenzer 2000-08-23 14:38:04 EDT
Looks like nroff doesn't handle .so correctly (it should automatically try
adding .gz, the way man does).
Comment 3 Trond Eivind Glomsrxd 2001-04-02 20:00:11 EDT
Still a problem.
Comment 4 Trond Eivind Glomsrxd 2002-05-14 16:53:39 EDT

*** This bug has been marked as a duplicate of 19555 ***

Note You need to log in before you can comment on or make changes to this bug.