Bug 19555 - man doesn't resolve includes of other man files properly
man doesn't resolve includes of other man files properly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: groff (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
: 10814 16338 21815 33680 41118 42490 50818 56947 57384 62525 64932 67158 69727 69732 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-22 16:23 EDT by dh_redhat
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-28 17:19:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dh_redhat 2000-10-22 16:23:12 EDT
Type 'man zshall', it will start with the following errors:

<standard input>:23: realpath on `man1/zshmisc.1' failed: No such file or 
directory
<standard input>:24: realpath on `man1/zshexpn.1' failed: No such file or 
directory
<standard input>:25: realpath on `man1/zshbuiltins.1' failed: No such file 
or directory
<standard input>:26: realpath on `man1/zshcompctl.1' failed: No such file 
or directory
<standard input>:27: realpath on `man1/zshparam.1' failed: No such file or 
directory
<standard input>:28: realpath on `man1/zshzle.1' failed: No such file or 
directory
<standard input>:29: realpath on `man1/zshoptions.1' failed: No such file 
or directory


Workaround:

su root
cd /usr/share/man/man1
gunzip zsh*
cd /var/cache/man/man1
rm zsh*
cd /
man zshall
exit

The problem is that zshall is a meta man page and it can't follow the 
links to the .gz sections like zshmisc, zshbuiltins, etc.
Comment 1 dh_redhat 2000-10-22 16:25:08 EDT
The version of zsh is zsh-3.0.8-3
Comment 2 Trond Eivind Glomsrxd 2000-10-22 16:42:57 EDT
Bero, man broke again.
Comment 3 dh_redhat 2000-10-23 00:25:27 EDT
I suspect there are other man pages that suffer of the same problem, e.g. links 
in them that cannot be resolved because all the man pages are gzipped.
Comment 4 Trond Eivind Glomsrxd 2000-12-06 16:44:44 EST
*** Bug 21815 has been marked as a duplicate of this bug. ***
Comment 5 Trond Eivind Glomsrxd 2001-03-28 16:09:26 EST
OK, I just changed the summary. Bero, this affects quite a few packages...
including "man-pages", "pvm", "zsh" - and these are just the ones I've seen the
problem in. Could you fix this ASAP? TIA.
Comment 6 Trond Eivind Glomsrxd 2001-03-28 16:09:53 EST
*** Bug 33680 has been marked as a duplicate of this bug. ***
Comment 7 Bernhard Rosenkraenzer 2001-04-25 04:54:00 EDT
I think the right fix is to make groff 
handle inclusions of gzipped stuff...
Comment 8 Trond Eivind Glomsrxd 2001-05-29 12:27:53 EDT
*** Bug 42490 has been marked as a duplicate of this bug. ***
Comment 9 Trond Eivind Glomsrxd 2001-05-29 12:30:16 EDT
*** Bug 41118 has been marked as a duplicate of this bug. ***
Comment 10 Trond Eivind Glomsrxd 2001-08-03 12:44:41 EDT
*** Bug 50818 has been marked as a duplicate of this bug. ***
Comment 11 Glen Foster 2001-10-19 16:00:52 EDT
Seeing same problem on s390 beta-tree
Comment 12 Trond Eivind Glomsrxd 2001-12-11 12:14:48 EST
*** Bug 57384 has been marked as a duplicate of this bug. ***
Comment 13 Trond Eivind Glomsrxd 2002-05-14 16:52:10 EDT
*** Bug 64932 has been marked as a duplicate of this bug. ***
Comment 14 Trond Eivind Glomsrxd 2002-05-14 16:53:33 EDT
*** Bug 10814 has been marked as a duplicate of this bug. ***
Comment 15 Trond Eivind Glomsrxd 2002-05-14 16:54:59 EDT
*** Bug 16338 has been marked as a duplicate of this bug. ***
Comment 16 Trond Eivind Glomsrxd 2002-05-14 16:55:17 EDT
*** Bug 56947 has been marked as a duplicate of this bug. ***
Comment 17 Trond Eivind Glomsrxd 2002-06-20 11:03:50 EDT
*** Bug 67158 has been marked as a duplicate of this bug. ***
Comment 18 Trond Eivind Glomsrxd 2002-07-24 16:30:30 EDT
*** Bug 69727 has been marked as a duplicate of this bug. ***
Comment 19 dh_redhat 2002-07-24 16:51:53 EDT
wow, i cannot believe this, i reported this bug almost 2 years ago and it is 
still not fixed, new bugs are still being marked as a dup of this one ... 
wasn't open source supposed to address all problems quickly?
Comment 20 Trond Eivind Glomsrxd 2002-07-26 17:01:02 EDT
*** Bug 69732 has been marked as a duplicate of this bug. ***
Comment 21 Tim Waugh 2002-10-07 07:15:33 EDT
*** Bug 62525 has been marked as a duplicate of this bug. ***
Comment 22 Florian La Roche 2003-02-28 17:19:54 EST
Took quite some time, but now the current rpm handels this.

greetings,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.