Bug 108166 - should use nroff on KNROFF
should use nroff on KNROFF
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-28 03:20 EST by David Joo
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.5m2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 19:49:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Joo 2003-10-28 03:20:57 EST
Description of problem:
Because we have two locale to deal with (new UTF-8 for ko_KR and EUC-KR), KNROFF
path should run  /usr/bin/nroff -c -mandoc instead of /usr/bin/groff -Tkorean
-mandoc to detect charset correctly and use the proper dev for groff

Version-Release number of selected component (if applicable):
1.5k-12

How reproducible:
everytime

Steps to Reproduce:
1. LANG=ko_KR.UTF-8 man man
    
Actual results:
does not show man

Expected results:
should show man in UTF-8

Additional info:
probably just s/KNROFF         /usr/bin/groff -Tkorean -mandoc/KNROFF         
/usr/bin/nroff -c -mandoc/ will be fine
Comment 1 Leon Ho 2003-12-07 19:32:19 EST
Does this solution okay to you? Anything that we can do on our end to
resolve this bug?
Comment 2 Eido Inoue 2003-12-08 12:26:53 EST
Looks ok. Will push the changes to fc2 first.
Comment 3 Eido Inoue 2004-01-26 19:49:03 EST
Korean will use the nroff script front-end as mentioned. There won't
be a separate knroff variable, though, because everything will be
unified to use one nroff (korean and japanese can both use nroff
because it checks the locale)

Note You need to log in before you can comment on or make changes to this bug.