Bug 108169 - Up2date fails with Traceback errors
Up2date fails with Traceback errors
Status: CLOSED DUPLICATE of bug 108085
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 05:44 EST by Shekhar
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shekhar 2003-10-28 05:44:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I ran up2date -ud, it fails with tracebabk errors.
ls /tmp shows thousands of .hdr files.

Version-Release number of selected component (if applicable):
up2date-4.1.11-3

How reproducible:
Always

Steps to Reproduce:
1. up2date -ud
2.
3.
    

Actual Results:  [root@dal4 root]# up2date -ud

Fetching package list for channel: rawhide...

Fetching http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info...
########################################

Fetching Obsoletes list for channel: rawhide...

Fetching obsoletes list for http://ftp.redhat.com/pub/redhat/linux/rawhide/...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1187, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 765, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1050, in batchRun
    batch.run()
  File "up2dateBatch.py", line 58, in run
  File "up2dateBatch.py", line 96, in __findPackagesToUpdate
  File "packageList.py", line 123, in run
  File "rhnPackageInfo.py", line 404, in obsoletesList
  File "rpcServer.py", line 110, in doCall
  File "repoDirector.py", line 27, in getObsoletes
  File "rpmSource.py", line 249, in getObsoletes
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 293, in
getObsoletes
    pkgList = self.pkglists[channel['label']]
KeyError: rawhide


Additional info:

I have changed the default download location from /var/spool/up2date to
/fedora0.95/updates. But I guess this shouldn't be a prob.
Comment 1 Michael Young 2003-10-28 09:38:51 EST
Duplicate of bug 108085.
Comment 2 Bill Nottingham 2003-10-28 10:46:50 EST

*** This bug has been marked as a duplicate of 108085 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.