Bug 1081697 - [RFE] Katello and Foreman Host and System integration
Summary: [RFE] Katello and Foreman Host and System integration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Infrastructure
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1187865 (view as bug list)
Depends On:
Blocks: 963325 1100284 GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-03-27 18:55 UTC by Bryan Kearney
Modified: 2019-09-26 13:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-07 13:28:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 8161 0 'Normal' 'Rejected' 'Host Unification' 2019-12-04 15:08:34 UTC

Description Bryan Kearney 2014-03-27 18:55:27 UTC
We need to better integrate Foreman Hosts and Katello Systems.  This includes a series of work to do the following:

* Rename Katello Systems to Hosts
* Build a datamodel where Katello Hosts are an extension or joined to a Foreman Host
* Build UI linking between Katello Hosts and Foreman Hosts 
* Ensure datamodel integrity such that hosts are created/updated/deleted in unison between Foreman and Katello
* Ensure that when API calls (eg, subscription-manager) create registered hosts that there are corresponding hosts created in Foreman's datamodel

We will break this out into multiple issues but track the overall feature here.

Comment 1 Bryan Kearney 2014-03-27 18:55:29 UTC
Created from redmine issue http://projects.theforeman.org/issues/4912

Comment 3 Bryan Kearney 2015-01-09 14:38:55 UTC
Upstream bug assigned to mmccune@redhat.com

Comment 4 Bryan Kearney 2015-04-17 18:50:38 UTC
*** Bug 1187865 has been marked as a duplicate of this bug. ***

Comment 5 Bryan Kearney 2015-08-24 15:28:01 UTC
Connecting redmine issue http://projects.theforeman.org/issues/8161 from this bug

Comment 6 Bryan Kearney 2015-08-25 17:23:17 UTC
Upstream bug component is WebUI

Comment 7 Bryan Kearney 2015-08-25 17:36:11 UTC
Upstream bug component is Content Management

Comment 8 Bryan Kearney 2016-08-10 18:14:48 UTC
Upstream bug component is Infrastructure

Comment 9 Bryan Kearney 2016-08-10 20:01:05 UTC
Upstream bug component is Content Management

Comment 10 Bryan Kearney 2016-08-10 22:00:55 UTC
Upstream bug component is Infrastructure

Comment 11 Bryan Kearney 2016-10-07 13:28:32 UTC
This was delivered with Satellite 6.2


Note You need to log in before you can comment on or make changes to this bug.