Bug 1100284 - [RFE]Registering a host (which is not provisioned by foreman) via rhsm should show up in foreman
Summary: [RFE]Registering a host (which is not provisioned by foreman) via rhsm should...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1081697
Blocks: 1161120 rhci-common-installer
TreeView+ depends on / blocked
 
Reported: 2014-05-22 12:29 UTC by Sachin Ghai
Modified: 2019-09-26 17:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:09:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
registered host appears under content-host (cloud-qe-09) (56.79 KB, image/png)
2016-04-05 10:36 UTC, Sachin Ghai
no flags Details
registered host appears under 'all hosts' (cloud-qe-09) (47.87 KB, image/png)
2016-04-05 10:36 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 9381 None None None 2016-04-22 15:09:21 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Sachin Ghai 2014-05-22 12:29:47 UTC
Description of problem:
Currently (with sat6 beta snap5 compose3), if I provisioned a host via foreman and later register it via rhsm.. the host is listed under content host. However on other hand, if I register a host (which is not provisioned by foreman) via rhsm, then it is listed only under content host, not under foreman hosts.

I think for host/system unification, it should be two way.

Version-Release number of selected component (if applicable):
sat6 beta snap5 compose3

 apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.9-1.el6sat.noarch
* foreman-compute-1.6.0.9-1.el6sat.noarch
* foreman-gce-1.6.0.9-1.el6sat.noarch
* foreman-libvirt-1.6.0.9-1.el6sat.noarch
* foreman-ovirt-1.6.0.9-1.el6sat.noarch
* foreman-postgresql-1.6.0.9-1.el6sat.noarch
* foreman-proxy-1.6.0.6-1.el6sat.noarch
* foreman-selinux-1.6.0-2.el6sat.noarch
* foreman-vmware-1.6.0.9-1.el6sat.noarch
* katello-1.5.0-24.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.40-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-plugins-0.3-1.el6sat.noarch
* pulp-nodes-common-2.4.0-0.17.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.17.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.17.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.17.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.17.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.17.beta.el6sat.noarch
* pulp-server-2.4.0-0.17.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* rubygem-hammer_cli-0.1.0-13.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.0-13.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.2-6.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.3-24.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. register a host (which is not provisioned by foreman) via rhsm
2. host is listed under content hosts but not under foreman host
3.

Actual results:
register a host (which is not provisioned by foreman) via rhsm, then it is listed only under content host, not under foreman hosts.

Expected results:
host should be listed under both sides ( under foreman hosts as well as content-hosts)

Additional info:

Comment 1 Dominic Cleal 2014-05-22 12:32:22 UTC
Related: http://projects.theforeman.org/issues/3506

Comment 2 RHEL Program Management 2014-05-22 12:46:41 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 jmagen@redhat.com 2014-07-21 08:52:05 UTC
I don't think Katello needs to create a Foreman host every time a content host is registered using subscription-manager. From what I understand, a content host that manages only RPM's doesn't need a Foreman host. If a content host also contains puppet modules, then the puppet master will import the facts and automatically create a Foreman (unmanaged) host after the next puppet run (every 30 minutes).

Comment 5 Sergio G. 2014-07-30 08:07:31 UTC
If I let puppet run create Foreman host, it's created without proper Organization, Location and Environment. 

From my use:
 - or subscription-manager process registers also Foreman host
 - or some kind of lookup, when receiving new hosts through Puppet master, needs to be done to create Foreman host in correct Organization/Location/Environment

Comment 6 Tom McKay 2015-02-13 20:41:41 UTC
Created redmine issue http://projects.theforeman.org/issues/9381 from this bug

Comment 7 Bryan Kearney 2015-08-25 17:23:31 UTC
Upstream bug component is WebUI

Comment 8 Bryan Kearney 2015-08-25 17:36:21 UTC
Upstream bug component is Content Management

Comment 11 Justin Sherrill 2016-02-16 18:35:57 UTC
This was resolved as part of hot unification work for 6.2, moving to POST

Comment 14 Sachin Ghai 2016-04-05 10:33:59 UTC
Verified with sat6.2 beta snap6

I registered an already provisioned host with sat6 server via rhsm and I can see that host under 'content-host' as well as 'All hosts'


Installed:
  katello-ca-consumer-cloud-qe-15.idmqe.lab.eng.bos.redhat.com.noarch 0:1.0-1                                                                         

Complete!
[root@cloud-qe-9 ~]# subscription-manager register --activationkey ak_rhel7 --org Default_Organization
The system has been registered with ID: f8e9a167-898a-4d0a-91c5-079c8bda2bce 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed

Unable to find available subscriptions for all your installed products.
[root@cloud-qe-9 ~]# 


Please see the attached screenshots from webUI for verification.

Comment 15 Sachin Ghai 2016-04-05 10:36:17 UTC
Created attachment 1143744 [details]
registered host appears under content-host (cloud-qe-09)

Comment 16 Sachin Ghai 2016-04-05 10:36:58 UTC
Created attachment 1143745 [details]
registered host appears under 'all hosts' (cloud-qe-09)

Comment 18 errata-xmlrpc 2016-07-27 09:09:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.