Bug 10829 - installation fails if no /dev/hda5 and is a /dev/hda6
Summary: installation fails if no /dev/hda5 and is a /dev/hda6
Status: CLOSED DUPLICATE of bug 10991
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-14 19:50 UTC by John Battista
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-27 14:13:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Battista 2000-04-14 19:50:41 UTC
This one is weird.  Our Micron notebook computer with NT 4.0 (+SP4) and RH
6.0 somehow has the root directory on /dev/hda6 and there is NO /dev/hda5.
I have no idea how the person here set this up.  The partitions are:
hda1 : FAT16
hda2 : extended (?)
hda3 : linux swap
hda4 : linux swap
(no hda5 listed)
hda6 : ext2fs (/ directory)
hda7, hda8, hda9 are also ext2fs partitions (usr, tmp, etc)
hda10 linux swap.

The RH 6.2 installation program dies when it cant find the hda5 partition.

I understand that the hard drive partition table may be corrupted, but this
machine has been working great since it was installed with NT/RH 6.0.

Comment 1 Jay Turner 2000-04-17 19:40:59 UTC
I have no idea how one would get a computer in this state, but that is definitly
a state that the machine should not be in.  With this being the case, I can only
say that the installer was never meant to deal with invalid partitions, so it is
not surprising that the installer is failing.  I would recommend reinstalling
the machine and recreating the partition table during the process.  What does
"fdisk -l /dev/hda" show?  I cannot come up with a way to get a hard drive in
this state.

Comment 2 Jay Turner 2000-04-27 14:13:59 UTC
*** This bug has been marked as a duplicate of 10991 ***


Note You need to log in before you can comment on or make changes to this bug.