Bug 10991 - Signal 11 on upgrade from 6.0
Signal 11 on upgrade from 6.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
: 10829 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-22 15:43 EDT by Tim Jung
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-26 14:34:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Jung 2000-04-22 15:43:50 EDT
I currently have RedHat 6.0 installed on a i486 AMD x5-133MHz with kernel
2.2.14.  I have tried many times to effect an upgrade, but if I choose
GUI mode, it just hangs, and text mode results in aborting with a signal 11
error.  At first, I thought that my Win/Linux storage partition crossing
the 1024 cylinder area might be the cause of it, so I shrank it, but the
problem persists.

Here is what my /sbin/fdisk -l looks like:

Disk /dev/hda: 64 heads, 63 sectors, 787 cylinders
Units = cylinders of 4032 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdc1   *       226      1013   6329578+   b  Win95 FAT32
/dev/hdc2             1       225   1807281    5  Extended
/dev/hdc5             1       217   1742989+  83  Linux
/dev/hdc6           218       225     64228+  82  Linux swap

I used partition Magic 5 to shrink /dev/hdc1 to under the 1024 cylinder
barrier, and even took that entry out of my /etc/fstab.

The method I was using to try the upgrade was booting from my boot floppy
and installing the upgrade from cd rom.
Comment 1 Jay Turner 2000-04-25 10:08:59 EDT
At what point in the upgrade is the text installer seg faulting?  Also, please
submit the output of "fdisk -l /dev/hda" so that we can truly reproduce the
situation in the test lab.
Comment 2 Anonymous 2000-04-26 02:15:59 EDT
here is my fdisk -l /dev/hda:

Disk /dev/hda: 64 heads, 63 sectors, 787 cylinders
Units = cylinders of 4032 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       735   1481728+   b  Win95 FAT32
/dev/hda2           736       786    102816    5  Extended
/dev/hda6           760       786     54400+   6  FAT16

The install fails with Signal 11 right after it says: Searching for Redhat components
while installing in text mode.  When installing in gfx mode, it hangs right after
clicking the next buttion on the upgrade page that allows you to select
customise packages.  After it freezes there, Ctrl Alt F1 shows that it was
running in VGA16 at 640x480 even though I normally run RH 6.0 Gnome in
800x600.  (Don't know if that is pertinent.)
Comment 3 Jay Turner 2000-04-26 09:05:59 EDT
OK, this is the second time that I have seen this bug and I am still pretty
clueless on how the partition table gets into the state that it is in, but at
least I know what the problem is.

The partition table on your hda drive is in a state that I am not aware is a
legal state.  Somehow your system has a hda6 partition without having a hda5
partition within the extended partition.  When the installer is searching the
system during the upgrade, it hits this inconsistency and then falls over.  So,
the Red Hat installer should probably have better error handling, but as far as
I know, this is not a valid partition table.

How did you create the partitions on your hda drive?
Comment 4 Anonymous 2000-04-26 12:09:59 EDT
As far as I remember, I believed that I used Partition Magic to manipulate
those partitions.  Would this fix the problem if I create another one in
the extended partition?
Comment 5 Jay Turner 2000-04-26 14:34:59 EDT
This is the result of a bug in Partition Magic which does not retain partition
table integrity when removing partitions.

Red Hat is working to handle this problem more gracefully, but at this point,
this is a closed bug.
Comment 6 Jay Turner 2000-04-27 10:13:59 EDT
*** Bug 10829 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.