Bug 1083642 - Numlock keyboard led turns off when I press some keyboard keys
Summary: Numlock keyboard led turns off when I press some keyboard keys
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
: 1289434 (view as bug list)
Depends On:
Blocks: 1202385
TreeView+ depends on / blocked
 
Reported: 2014-04-02 15:50 UTC by Benjamin Bellec
Modified: 2016-11-04 02:49 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 02:49:37 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2293 normal SHIPPED_LIVE X.Org X11 server and drivers bug fix and enhancement update 2016-11-03 13:38:01 UTC
GNOME Bugzilla 719846 None None None Never
Red Hat Bugzilla 1047151 None None None Never

Description Benjamin Bellec 2014-04-02 15:50:20 UTC
I just wanted to share a bug, not a blocker one at all, but really silly for an Enterprise distribution from my point of view.
It hits RHEL 7.0 Beta.

Here is the upstream report:
https://bugzilla.gnome.org/show_bug.cgi?id=719846

Also reported here:
https://bugzilla.redhat.com/show_bug.cgi?id=1047151
https://bugs.archlinux.org/task/36091

Comment 2 RHEL Product and Program Management 2014-04-10 05:47:23 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Benjamin Bellec 2014-04-10 07:29:51 UTC
If this can't be updated for RHEL 7.0, it would be great if this can be fixed in RHEL 7.1.

Comment 4 Stephen John Smoogen 2014-05-05 23:57:49 UTC
Looking at the gnome side of the bug it looks like you need to change components from gnome to the X server as keyboard layout changes are 'really' controlled at that level versus the gnome-settings.

Comment 5 Fred New 2015-02-25 12:17:31 UTC
I'm seeing this problem in Fedora 20 as well. NumLock turns off when I use shift while entering my password in the GDM login screen -
xorg-x11-server-common-1.14.4-14.fc20.x86_64
xorg-x11-server-Xorg-1.14.4-14.fc20.x86_64
xorg-x11-server-utils-7.7-6.fc20.x86_64

Comment 6 Robert Mason 2015-03-10 10:31:50 UTC
I think I'm experiencing the same thing in Fedora 21. I'm using a UK keyboard and UK keyboard layout.

Pressing the shift key turns the numlock light off, but the numpad actually still works. At this point pressing numlock key turns numlock off, and the light is still off. Pressing the numlock key a second time turns numlock and the light on.

Comment 7 Fred New 2015-03-10 10:56:35 UTC
Good catch about it just being the NumLock light, Robert. Estonian keyboard and now Fedora 21 here. As I finish logging in, the light comes back on, but as soon as I press the Windows key (big-L?) the light turns off. If I start gnome terminal or gedit, I can see that the numeric pad still enters numbers.

Current xorg-x11-server components:
xorg-x11-server-Xwayland-1.16.3-2.fc21.x86_64
xorg-x11-server-Xorg-1.16.3-2.fc21.x86_64
xorg-x11-server-common-1.16.3-2.fc21.x86_64
xorg-x11-server-utils-7.7-10.fc21.x86_64

Comment 8 Christopher Beland 2015-04-29 17:24:05 UTC
FTR, the Fedora 21+ bug is Bug 115909.

Comment 9 Christopher Beland 2015-04-30 17:46:34 UTC
FYI, with Fedora 22 beta, I can't reproduce this problem with a US keyboard.

Comment 10 Christopher Beland 2015-04-30 18:14:58 UTC
Correction, I can reproduce now.  Steps listed in Bug 1047151 for Fedora; I'm closing the other one since it mixes too many issues.

Comment 11 Peter Hutterer 2016-05-05 00:41:35 UTC
MODIFIED

xorg-x11-server-1.17.2-15.el7 is available in brew

Comment 13 Peter Hutterer 2016-05-05 04:43:06 UTC
*** Bug 1289434 has been marked as a duplicate of this bug. ***

Comment 14 Peter Hutterer 2016-06-28 04:40:32 UTC
MODIFIED 

xorg-x11-server-1.17.2-17.el7 is available in brew

Comment 18 errata-xmlrpc 2016-11-04 02:49:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2293.html


Note You need to log in before you can comment on or make changes to this bug.