Bug 1047151 - Numlock LED incorrect after keyboard map switch [NEEDINFO]
Summary: Numlock LED incorrect after keyboard map switch
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 22
Hardware: i686
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1315090 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-29 13:47 UTC by jean-filip tripcevic
Modified: 2016-05-13 02:48 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-07 21:50:52 UTC
peter.hutterer: needinfo?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 719846 None None None Never

Internal Trackers: 1083642

Description jean-filip tripcevic 2013-12-29 13:47:23 UTC
Description of problem:
When user's gnome-session starts with Numlock LED on pressing any of the following keys: Shift, Cntrl, Alt or win will cause the Numlock LED to turn off although the Numlock function remains on. If one then presses CAPS_LOCK key the Numlock LED will turn back on along with the CAPS_LOCK LED (similar to  BUG 151779). This seems to correct the problem and the Numlock LED functions as it should normally until the user quits the session and begins another.

Version-Release number of selected component (if applicable):
gnome-shell-3.10.2.1-3.fc20.i686

How reproducible:
every time

Steps to Reproduce:
1.start new gnome-shell session
2.Numlock LED should be on after session starts. If not press Numlock key until LED turns on then quit session and start a new one.
3.Press and release any of the following keys: Shift, Cntrl, Alt, or Win

Actual results:
Numlock LED turns off

Expected results:
Numlock LED remains on

Additional info:
I had been running F18 since it's release on this PC and did not have this problem until I installed F20 on it (not an upgrade. Fresh install).
I've installed Mate and tried it and did not have the problem.

Comment 1 Benjamin Bellec 2014-02-16 13:15:52 UTC
Upstream bug is here:
https://bugzilla.gnome.org/show_bug.cgi?id=719846

This also hits Gnome 3.8, so Fedora 19 and most importantly RHEL7.

Comment 2 jean-filip tripcevic 2014-02-17 04:37:10 UTC
Workaround for this bug that works for me:
1.Insure that numlockx is installed. If not install it.
2.Create the following shell script accessible by all:
  #!/bin/bash
  numlockx off
  sleep 5
  numlockx on
3.Add this script to user's gnome-session-properties start-up applications.

Comment 3 Christopher Beland 2015-04-30 18:16:53 UTC
I can't reproduce this as described with a US keyboard, but these steps from the upstream Gnome bug *do* reproduce for me on Fedora 22 beta:

>>>
1. $ setxkbmap us
2. enable NumLock
3. $ setxkbmap br
4. press any modifier key

At this point the numlock led turn off and the keycodes sent for those keys are indeed the original (non numlocked) ones.
<<<

Bug 1083642 is the same thing for RHEL 7.

Comments in the Gnome bug suggest this is a problem with the X server, so changing the component.


Possibly related: Bug 1217582 - Numlock light stays on after logout but can't type numbers from numpad

Comment 4 Peter Hutterer 2016-04-29 06:18:20 UTC
ok, I think I finally found the reason why. A test patch is available in this F23 scratch build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=13844561

This bug is for F22 but I figured maybe by now you have updated to F23 :)
afaict this works now, especially the reproducer from comment 3. Please let me know of any side-effects you discover.

Comment 5 Benjamin Bellec 2016-05-01 22:48:59 UTC
Your patch/rpm fixes the numlock issue for me.
Tested on F23.
Thanks!

Comment 6 Fedora Update System 2016-05-04 22:52:35 UTC
xorg-x11-server-1.18.3-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2f8b12e17

Comment 7 Fedora Update System 2016-05-04 23:50:53 UTC
xorg-x11-server-1.18.3-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a3c46c3acd

Comment 8 Fedora Update System 2016-05-05 09:54:10 UTC
xorg-x11-server-1.18.3-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a3c46c3acd

Comment 9 Fedora Update System 2016-05-05 15:52:20 UTC
xorg-x11-server-1.18.3-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2f8b12e17

Comment 10 Fedora Update System 2016-05-07 21:50:48 UTC
xorg-x11-server-1.18.3-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-05-08 10:30:17 UTC
xorg-x11-server-1.18.3-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 fujiwara 2016-05-13 02:48:38 UTC
*** Bug 1315090 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.