Bug 108395 - [PATCH] Gnome-panel autohides when moving applet
Summary: [PATCH] Gnome-panel autohides when moving applet
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
: 105985 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-28 22:35 UTC by Leonard den Ottolander
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 2.4.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 15:48:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to avoid gnome-panel from autohiding when moving icon (1.12 KB, patch)
2004-02-11 05:15 UTC, Leonard den Ottolander
no flags Details | Diff
SPEC file to accompany autohide patch (15.46 KB, text/plain)
2004-02-11 05:20 UTC, Leonard den Ottolander
no flags Details
patch to avoid gnome-panel from autohiding when moving icon (749 bytes, patch)
2004-02-19 10:04 UTC, Leonard den Ottolander
no flags Details | Diff

Description Leonard den Ottolander 2003-10-28 22:35:09 UTC
Description of problem:

 The Gnome panel autohides when moving an applet. Imo it should be visible
during the whole operation.


Version-Release number of selected component (if applicable):

 gnome-panel-2.4.0-3

Comment 1 Bart Martens 2004-02-11 00:32:56 UTC
Patch available.
http://bugzilla.gnome.org/show_bug.cgi?id=122863


Comment 2 Leonard den Ottolander 2004-02-11 05:15:46 UTC
Created attachment 97579 [details]
patch to avoid gnome-panel from autohiding when moving icon

Cleaned up to patch against FC1.

Works for me. This patch is so simple that I don't believe it will cause any
side effects. Move to testing.

Comment 3 Leonard den Ottolander 2004-02-11 05:20:10 UTC
Created attachment 97580 [details]
SPEC file to accompany autohide patch

Comment 4 Leonard den Ottolander 2004-02-12 15:53:20 UTC
Setting version to 1 and adding [PATCH] to subject line.


Comment 5 Leonard den Ottolander 2004-02-19 10:04:37 UTC
Created attachment 97828 [details]
patch to avoid gnome-panel from autohiding when moving icon

Removed Changelog hunk

Comment 6 Mark McLoughlin 2004-02-20 15:08:53 UTC
Should be fixed in Raw Hide. Also, fix is in gnome-panel 2.4.2 which
I'm going to release as an FC1 update ... hopefully next week.

Comment 7 Leonard den Ottolander 2004-02-23 10:37:38 UTC
This appears to be a DUPLCITE of 105985. Not sure which one to close
since the other bug is for RawHide.


Comment 8 Mark McLoughlin 2004-02-23 10:48:09 UTC
Leonard: should be fine to mark the other one as a duplicate of this.
Thanks :)

Comment 9 Leonard den Ottolander 2004-02-23 11:05:33 UTC
I meant not sure which one should be closed. I have no bugzilla rights
for bugs that are not mine.


Comment 10 Mark McLoughlin 2004-02-23 11:16:50 UTC
*** Bug 105985 has been marked as a duplicate of this bug. ***

Comment 11 Mark McLoughlin 2004-02-23 22:43:49 UTC
I've just released a testing update which should fix this issue.
Please test it out and let us know if it fixes your problem.

Details on the update:
http://www.redhat.com/archives/fedora-test-list/2004-February/msg01512.html

Comment 12 Paul Dickson 2004-02-28 04:56:47 UTC
After a few hours of testing the testing update, it appears to resolve
all of my problems with gnome-panel.  Including my unreported bug of
the panel popping up (and staying up) if the mouse mometarily bumps
the panel (requiring the mouse moved again to the panel to get the
panel to hide).

Thanks for the work.

Comment 13 Bart Martens 2004-02-28 07:29:14 UTC
As you're thanking for the work, I think it's appropriate to mention
that the patch was written by Vijaykumar Patwari. That wasn't
mentioned here yet.
http://bugzilla.gnome.org/show_bug.cgi?id=122863

I think that "unreported bug" is reported, see bug #104178.


Comment 14 Mark McLoughlin 2004-03-02 15:48:08 UTC
Okay, a gnome-panel Fedora Core 1 Update (2.4.2-3) is 
now available from:

   http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/


Note You need to log in before you can comment on or make changes to this bug.