Bug 1084018 - [RFE] Add IdM user password change support for legacy client compat tree
Summary: [RFE] Add IdM user password change support for legacy client compat tree
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa   
(Show other bugs)
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: thierry bordaz
QA Contact: Namita Soman
Marc Muehlfeld
URL:
Whiteboard:
Keywords: FutureFeature
Depends On: 1084304 1344414
Blocks: 1084047
TreeView+ depends on / blocked
 
Reported: 2014-04-03 12:21 UTC by Martin Kosek
Modified: 2016-11-04 05:43 UTC (History)
6 users (show)

Fixed In Version: slapi-nis-0.56.0-1.el7.src.rpm 389-ds-base-1.3.5.5-1.el7 ipa-4.4.0-1.el7
Doc Type: Enhancement
Doc Text:
Password changes on legacy IdM clients Previously, Red Hat Enterprise Linux contained a version of _slapi-nis_ that does not enable user to change their passwords on legacy Identity Management (IdM) clients. As a consequence, users logged in to clients via the slapi-nis compatibility tree could only update their password using the IdM web UI or directly in Active Directory (AD). A patch has been applied to and as a result, users are now able to change their password on legacy IdM clients.
Story Points: ---
Clone Of:
: 1084047 (view as bug list)
Environment:
Last Closed: 2016-11-04 05:43:59 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Martin Kosek 2014-04-03 12:21:53 UTC
Description of problem:

Legacy client tree in RHEL-7 supports:
- Identity for IPA and AD users (RFE in Bug 1002649)
- Authentication (LDAP BIND) for IPA and AD users (RFE in Bug 1002649)

However, it does not have password change support so that it is properly routed either to IPA or AD.

slapi-nis upstream ticket:
https://fedorahosted.org/slapi-nis/ticket/4

Comment 1 Martin Kosek 2016-06-10 07:25:59 UTC
Thierry managed to advance with development of this RFE. It requires 3 modifications:

* 389-ds-base: it should support registration of pre/post extended operation and call them upon extended operation (Bug 1344414)

* ipapwd_extop: It should retrieve from the pb a target_DN set by the pre-extop callback and use it as the operation DN (this Bug, i.e. upstream ticket https://fedorahosted.org/freeipa/ticket/5946)

* slapi-nis: register a pre-extop that catch the password change and translate the requested DN, if it is mapped, into the real DN (Bug 1084304)

Comment 4 Martin Kosek 2016-07-21 14:59:06 UTC
Jan, do you also want to bump Requires in ipa with the new required builds:
slapi-nis-0.56.0-1.el7.src.rpm
389-ds-base-1.3.5.5-1.el7
?

Comment 5 Jan Cholasta 2016-08-10 08:54:52 UTC
Martin, no Requires bump is required, as this change was pulled in with the rebase in ipa-4.4.0-1.el7.

Comment 7 Sudhir Menon 2016-08-19 06:09:06 UTC
Marking the bug verified as per #comment10 in bz1084304

Comment 9 errata-xmlrpc 2016-11-04 05:43:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.