Bug 108412 - Attempting to run neat causes an assertion in dlgMain(). See attachments.
Summary: Attempting to run neat causes an assertion in dlgMain(). See attachments.
Status: CLOSED DUPLICATE of bug 86060
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-29 05:24 UTC by Herman R. Willett
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Herman R. Willett 2003-10-29 05:24:46 UTC
Description of problem:

Can not configure network interfaces using redhat-config-network or neat.

Version-Release number of selected component (if applicable):
RH9

How reproducible:
neat & <cr>
readhat-config-network & <cr>


Steps to Reproduce:
1.
2.
3.
    
Actual results:
Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/lib/python2.2/site-
packages/rhpl/exception.py:280:handleException:TypeError: generic_error_dialog
() got an unexpected keyword argument 'dialog_type'
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 169, in ?
    handleException(sys.exc_info(), PROGNAME, PRG_VERSION)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 280, in 
handleException
    dialog_type = "info")
TypeError: generic_error_dialog() got an unexpected keyword 
argument 'dialog_type'

Local variables in innermost frame:
fs: <rhpl.exception.FileSelection instance at 0x86a1f54>
type: exceptions.NameError
text: Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py:198:__init__:NameError: global 
name 'timeout_add' is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 198, in __init__
NameError: global name 'timeout_add' is not defined

list: ['Traceback (most recent call last):\n', '  File "/usr/sbin/redhat-config-
network-gui", line 154, in ?\n    window = mainDialog()\n', '  
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 198, in __init__\n', "NameError: 
global name 'timeout_add' is not defined\n"]
progname: redhat-config-network
value: global name 'timeout_add' is not defined
tb: <traceback object at 0x866f0c4>
extxt: ["NameError: global name 'timeout_add' is not defined\n"]
version: 1.2.0
t: __init__
file: /home/herman/neat-dump.txt
rc: -5
.0: (<class exceptions.NameError at 0x81179a4>, <exceptions.NameError instance 
at 0x86a1e9c>, <traceback object at 0x866f0c4>)
tblast: ('/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py', 198, '__init__')
out: <closed file '/home/herman/neat-dump.txt', mode 'w' at 0x86b6808>

===== AND =====

Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py:198:__init__:NameError: global 
name 'timeout_add' is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 198, in __init__
NameError: global name 'timeout_add' is not defined

Local variables in innermost frame:
widget: <gtk.VBox object (GtkVBox) at 0x866f094>
notebook: <gtk.Notebook object (GtkNotebook) at 0x86664dc>
page: 0
glade_file: /usr/share/redhat-config-network/netconfpkg/gui/maindialog.glade
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x860063c>

Expected results:

Graphical configuration dialog.

Additional info:

Comment 1 Harald Hoyer 2003-10-30 14:21:35 UTC

*** This bug has been marked as a duplicate of 86228 ***

Comment 2 Harald Hoyer 2003-10-30 14:24:23 UTC
An errata has been issued which should help the problem described in the above
bug report. 
This report is therefore being closed with a resolution of ERRATA. For more
information on the solution and/or where to find the updated files, please
follow the link below. 
You may reopen this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html

*** This bug has been marked as a duplicate of 86060 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:59:32 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.