Bug 1084497 - KDE cannot disable automount for removable media
Summary: KDE cannot disable automount for removable media
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-runtime
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1479818
TreeView+ depends on / blocked
 
Reported: 2014-04-04 13:54 UTC by Bill Sanford
Modified: 2018-10-26 07:58 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-10 11:31:43 UTC


Attachments (Terms of Use)
Screenshot of the USB mount options not working in System Settings (468.37 KB, image/jpeg)
2014-04-04 13:54 UTC, Bill Sanford
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0717 None None None 2018-04-10 11:33 UTC

Description Bill Sanford 2014-04-04 13:54:14 UTC
Created attachment 882719 [details]
Screenshot of the USB mount options not working in System Settings

Description of problem:
Using a USB thumb drive, RHEL 7 using KDE will automatically mount removable devices that "System Settings" in KDE totally disables. 

The steps I took to disable the KDE automount, it is in System Settings -> Removable Devices -> Uncheck all 4 check boxes, Click Apply, then relogin as that same user.

You will also see in the screenshot that when the USB is in, the properties of the USB thumb drive using the "Disks" utility program, shows the "Edit Mount Options" of that drive to have "Automatic Mount Options" still set to on.

Version-Release number of selected component (if applicable):
RHEL-7.0-20140317.0 
kde-runtime-4.10.5-7.el7.x86_64

How reproducible:
100%


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Product and Program Management 2014-04-12 05:47:25 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Jan Grulich 2016-04-07 07:25:59 UTC
Is this bug still reproducible with RHEL 7.2?

Comment 4 Bill Sanford 2016-08-04 19:41:46 UTC
I just installed RHEL-7.3-20160729.1 and it is still a problem.

kde-runtime-4.10.5-8.el7.x86_64

Comment 6 Jan Grulich 2017-09-19 19:50:31 UTC
Fixed in kde-runtime-4.10.5-10.el7.

I wasn't able to reproduce this problem after I fixed bug 1084191, but what I did is that I made automount overrides (the view with mounted devices) enabled all the time, because this forces to mount devices regardless any checkbox above. I also think that what you have configured in "Disks" utility program you mentioned has nothing to do with automount options in KDE.

Comment 9 Bill Sanford 2018-02-15 14:49:50 UTC
Verified with kde-runtime-4.10.5-11.el7

Comment 12 errata-xmlrpc 2018-04-10 11:31:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0717


Note You need to log in before you can comment on or make changes to this bug.