Bug 108473 - 3c59x + kudzu == boom
3c59x + kudzu == boom
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
: Reopened
: 108465 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-29 16:40 EST by Seth Lepzelter
Modified: 2013-07-02 22:16 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:33:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
relevant entries from /var/log/messages (6.54 KB, text/plain)
2003-10-29 16:44 EST, Seth Lepzelter
no flags Details

  None (edit)
Description Seth Lepzelter 2003-10-29 16:40:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
If the 3c59x module is loaded, but no communication is attemped, it appears
fine.  Once communication is attempted, it never actually succeeds, and the
console fills up with messages about dirty registers.

I'll attach a sample from messages.

here's the beginning of the message:
Flags; bus-master 1, dirty 1(1) current 1(1)
Transmit list 00000000 vs. c3f71240.
0: @c3f71200  length 8000002a status 8000002a
1: @c3f71240  length 00000000 status 00000000
2: @c3f71280  length 00000000 status 00000000
3: @c3f712c0  length 00000000 status 00000000
...

BTW, the fibre version of the card appears to work flawlessly.

Version-Release number of selected component (if applicable):
kernel-2.4.21-4.EL

How reproducible:
Always

Steps to Reproduce:
1. install a 3c905TX
2. attempt communication

Actual Results:  no communication succeeds, cryptic messages on the console

Expected Results:  should be able to communicate flawlessly.

Additional info:

I'll attach the relevant lines from messages.

The hardware that it's been tried on are:
Asus A7N8X and
Abit KR7A

The 3com cards are known to be fine, worked with WS 2.1 and currently work with
windows XP/2000.
Comment 1 Seth Lepzelter 2003-10-29 16:44:43 EST
Created attachment 95591 [details]
relevant entries from /var/log/messages
Comment 2 Uwe Beck 2003-11-06 14:29:47 EST
See bug #102685!
It is known since 2003-08-19.
An attention: you can only reproduce this bug with the Boomerang card!
Comment 3 Dan Gennidakis 2003-11-09 00:30:11 EST
Turn Kudzu off at runlevel boot with chkconfig --level 345 off. Then 
reboot and the nic should work. Let me know if that works. Thanks
Comment 4 Seth Lepzelter 2003-11-10 11:43:02 EST
Appears to be working beautifully.
Comment 5 Jeff Garzik 2004-01-12 14:29:11 EST
*** Bug 108465 has been marked as a duplicate of this bug. ***
Comment 6 Jeff Garzik 2004-01-12 14:37:33 EST

*** This bug has been marked as a duplicate of 107389 ***
Comment 8 Red Hat Bugzilla 2007-02-05 14:05:37 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 9 RHEL Product and Program Management 2007-10-19 15:33:31 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.