Bug 10848 - Use of spaces or periods in lilo label
Use of spaces or periods in lilo label
Status: CLOSED DUPLICATE of bug 10551
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Depends On:
  Show dependency treegraph
Reported: 2000-04-15 22:16 EDT by mcr
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-04-24 11:16:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mcr 2000-04-15 22:16:48 EDT
I'm not sure if this is a bug in the installer or in lilo.

I performed a custom install of RH6.2 using the x installer.  I changed
the lilo label to "Redhat 6.2".  lilo evidently does not like either
spaces or periods in it's labels.  When the install completed and lilo was
run, lilo indicated an error in the lilo.conf file.  The installer,
however, did not detect the error and rebooted my system without
complaint.  Since lilo did not install the boot loader, the system was
left in an unbootable state; it would print out LI (the first two letters
of the LILO: prompt) then freeze.  I was able to use a boot floppy, edit
the lilo.conf and rerun lilo, fixing the system.

I checked the man pages for lilo.conf and was unable to find any mention
of restrictions on the label= line. If limitations against using spaces or
periods are not documented, I'd consider this a bug in lilo.  If these
restrictions are documented, the installer should check for valid input.
It should, in any event, monitor lilo for error conditions and at minimum
allow you to edit the lilo.conf before completing the installation and
Comment 1 Jay Turner 2000-04-17 11:30:59 EDT
You are correct that the label line in the lilo.conf file cannot contain
spaces.  I am forwarding this issue to a developer for clarification in future
Comment 2 Jay Turner 2000-04-24 11:16:59 EDT
*** This bug has been marked as a duplicate of 10551 ***

Note You need to log in before you can comment on or make changes to this bug.