Bug 10551 - Install builds lilo.conf erroneously when using space ' ' in label
Summary: Install builds lilo.conf erroneously when using space ' ' in label
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
: 10848 11178 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-03 17:40 UTC by Peter Burkholder
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-12 18:39:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Burkholder 2000-04-03 17:40:39 UTC
I recently did a network install of RedHat 6.2 using the
text-based installer program.  When prompted for lilo boot
label, I entered "redhat 6.2".

The system would not reboot from the hard driving, hanging
at the  words:
"LI"

I rebooted using a boot floppy.  The lilo.conf file as built
by installer read:

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
default=redhat 6.2

image=/boot/vmlinuz-2.2.14-5.0
	label=redhat 6.2
	read-only
	root=/dev/hda6

Running /sbin/lilo produced:

Syntax error near line 8 in file /etc/lilo.conf

Changing the lilo conf file so I used "redhat_6.2"
worked for running lilo and for booting.
installed Redhat

Comment 1 Jay Turner 2000-04-24 15:16:59 UTC
*** Bug 10848 has been marked as a duplicate of this bug. ***

Comment 2 Jay Turner 2000-05-03 11:10:59 UTC
*** Bug 11178 has been marked as a duplicate of this bug. ***

Comment 3 Michael Fulbright 2000-06-12 18:39:32 UTC
The future releases of the installer will not allow a space to be inserted in
lilo labels.


Note You need to log in before you can comment on or make changes to this bug.