Bug 108562 - Anaconda loader fails to GET files from IIS 6 web server
Anaconda loader fails to GET files from IIS 6 web server
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
: 127620 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 01:01 EST by Glenn Mills
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 17:55:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glenn Mills 2003-10-30 01:01:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; TESIEAK6a)

Description of problem:
When attempting a kickstart build using the http build method, the boot CD 
loader fails to download the ks.cfg file from a Microsoft IIS6 Web server. An 
Apache Web Server works OK.

A network trace shows that the HTTP GET string is terminated with a \t\n when 
it should probably be \r\n.

Line 445 in the Anaconda loader source file ftp.c, was changed so that the HTTP 
GET string was terminated with \r\n and then recompiled.

After including the new loader binary into the initrd.img on the boot CD, we 
were able to download files from the IIS server and the build completed 
successfully.


Version-Release number of selected component (if applicable):
anaconda-7.2

How reproducible:
Always

Steps to Reproduce:
1.Create boot CD from isolinux on install CD's
2.Publish ks.cfg and build tree on Microsoft IIS 6 Web Server
3.Attempt a kickstart build
    

Additional info:
Comment 1 Jeremy Katz 2003-11-02 22:13:41 EST
Good catch, fixed in CVS 
Comment 2 Jason 2004-02-10 19:49:24 EST
This is also a problem with fedora core 1 and up2date.
Comment 3 Brent Fox 2004-04-16 17:55:28 EDT
Jason: If the problem you are seeing is with up2date, then you should
file a bug against up2date.
Comment 4 Jeremy Katz 2004-07-12 13:30:35 EDT
*** Bug 127620 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.