This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 127620 - Kickstart fails with IIS 6.0
Kickstart fails with IIS 6.0
Status: CLOSED DUPLICATE of bug 108562
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-10 22:22 EDT by Damon T. Miller
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Damon T. Miller 2004-07-10 22:22:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7)
Gecko/20040614 Firefox/0.9

Description of problem:
When provisioning a RedHat AS 3 server using Kickstart via HTTP, the
GET is incorrectly formed.  This causes webservers doing strict HTTP
compliance checks (such as IIS 6.0) to return a 404 - "Bad Request". 
Judging from an Ethereal capture, I think the problem lies in the
termination of the request itself.  Specifically, instead of "\r\n",
the request is terminated with "\t\n".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Configure a provisioning environment using IIS 6.0 and KickStart
over HTTP.

2.  Initiate the process.    

Actual Results:  Of course, step #1 is a rather lengthy process and
varies from vendor to vendor, however this is reproducible every time
when using IIS 6.0.

Expected Results:  Kickstart should have successfully retrieved the
.cfg file and proceeded with unattended installation.

Additional info:

Here is a text dump of the relevant section from an Ethereal packet
capture:

--

4047 21.997415   192.168.65.106        192.168.65.1          TCP     
32768 > http [SYN] Seq=0 Ack=0 Win=5840 Len=0 MSS=1460 TSV=2088 TSER=0
WS=0
   4048 21.997457   192.168.65.1          192.168.65.106        TCP  
   http > 32768 [SYN, ACK] Seq=0 Ack=1 Win=17640 Len=0 MSS=1260 WS=0
TSV=0 TSER=0
   4049 21.998926   192.168.65.106        192.168.65.1          TCP  
   32768 > http [ACK] Seq=1 Ack=1 Win=5840 Len=0 TSV=2089 TSER=0
   4050 22.002055   192.168.65.106        192.168.65.1          HTTP 
   GET /./pxestore/00-0C-29-C0-34-2C.cfg HTTP/1.0\t
   4051 22.002584   192.168.65.1          192.168.65.106        HTTP 
   HTTP/1.1 400 Bad Request (text/html)
   4052 22.003958   192.168.65.106        192.168.65.1          TCP  
   32768 > http [RST, ACK] Seq=71 Ack=151 Win=5840 Len=0 TSV=2090
TSER=269716

--
Comment 1 Jeremy Katz 2004-07-12 13:30:33 EDT

*** This bug has been marked as a duplicate of 108562 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.