Bug 108618 - [RFE] please split off -devel package with proper dependencies .
Summary: [RFE] please split off -devel package with proper dependencies .
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 108677 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-30 18:39 UTC by Michael Schwendt
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 2.5.91-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 14:37:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2003-10-30 18:39:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031027

Description of problem:
Package gnome-panel contains C headers and pkgconfig files.

But it doesn't depend on any -devel packages which would satisfy its requirements.

Software developers who develop for gnome-panel would need to solve missing
dependencies manually in order to make the included pkgconfig support work.
Packagers would need to add explicit dependencies, too, before a package would
build.

The included libpanelapplet-2.0.pc pkgconfig file lists

  gtk+-2.0
  libgnomeui-2.0
  libbonoboui-2.0

so a separate gnome-panel-devel should require the corresponding -devel packages 

  gtk2-devel
  libgnomeui-devel
  libbonoboui-devel

I don't know whether Red Hat support pkgconfig to that level. That's why I file
this as an RFE instead of a bug. But it would be really helpful if the
dependencies of -devel packages matched the dependencies of included pkgconfig
templates. Everything else is a dependency nightmare.


Version-Release number of selected component (if applicable):
gnome-panel-2.4.0-3

Comment 1 Miloslav Trmac 2004-02-18 15:48:57 UTC
*** Bug 108677 has been marked as a duplicate of this bug. ***

Comment 2 Leonard den Ottolander 2004-02-24 00:51:03 UTC
The test update to gnome-panel-2.4.2-1 does not solve this issue yet.
Don't rush to push to the main tree. You don't want to do many updates
to the main tree in a short time.

If you give this a week or two we can probably resolve a significant
part of the outstanding bugs with a single update.


Comment 3 Mark McLoughlin 2004-03-02 14:37:33 UTC
Fixed in Raw Hide


Note You need to log in before you can comment on or make changes to this bug.