Bug 1086656 - Cannot enabled second display after disabled it in guest with "Display Perference"
Summary: Cannot enabled second display after disabled it in guest with "Display Perfer...
Status: CLOSED DUPLICATE of bug 1086657
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-qxl
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 1086657 1349852
TreeView+ depends on / blocked
 
Reported: 2014-04-11 09:11 UTC by CongDong
Modified: 2016-06-24 11:27 UTC (History)
9 users (show)

(edit)
Clone Of:
: 1086657 (view as bug list)
(edit)
Last Closed: 2014-06-25 05:01:20 UTC


Attachments (Terms of Use)

Description CongDong 2014-04-11 09:11:15 UTC
Description of problem:
If disable the second monitor with "Display Preference", then cannot find "Monitor 2" and enabled it again.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.7-7.el7.x86_64

How reproducible:
60%

Steps to Reproduce:
1. Prepare a rhel6 guest with spice graphic.
2. # virt-viewer rhel6
   Open display 2, make sure the two displays are all work well.
3. Open "Display Preference" in guest.
   System -> Preferences -> Display
4. Choose the monitor which correspond to display 2, and choose "Off", then click "Apply"
   Now, display 2 should be disconnected, and monitor 2 is turned black.
5. Close display 2 by virt-viewer's "view" menu and close "Display preference"
6. Reopen "Display preference", after that open display 2.
   Now, display 2 is disconnected, and status of monitor 2 in "Display preference" is "off"
7. Choose monitor 2 and turn it on.

Actual results:
Step7, after turn monitor 2 on, display 2 is still disconnected, and monitor 2 is disappeared in "Display preference".

Expected results:
Can enable monitor 2 sucessfully.

Additional info:

Comment 2 Jonathon Jongsma 2014-04-11 15:08:49 UTC
This is expected behavior.

Comment 3 Jonathon Jongsma 2014-04-16 14:51:25 UTC
Since this appears to be a bug in the guest rather than in virt-viewer, closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 1086657 ***

Comment 4 Cui Lei 2014-06-24 08:15:24 UTC
It is the same bug but which existed in RHEL7, usually we keep the bug open for tracking it in RHEL7, so open the bug.

Comment 5 Marc-Andre Lureau 2014-06-24 12:44:09 UTC
(In reply to Cui Lei from comment #4)
> It is the same bug but which existed in RHEL7, usually we keep the bug open
> for tracking it in RHEL7, so open the bug.

it should be closed because the bug is not in the client but in the guest.

Comment 6 Cui Lei 2014-06-25 05:01:20 UTC
Codong has just confirmed this issue is a guest issue, which only existed in RHEL6 guest.
So close this issue as duplicate.

*** This bug has been marked as a duplicate of bug 1086657 ***


Note You need to log in before you can comment on or make changes to this bug.