Bug 108693 - Diamond Stealth S220 problem
Diamond Stealth S220 problem
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-31 04:44 EST by Robert Prewitt
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version: 4.3.0-43
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-02 19:58:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Prewitt 2003-10-31 04:44:37 EST
Description of problem:

1. Installation of RH9 freezes when probing DDC. 
2. Using Driver "vga" X works, but in an obscure resolution, 120x120 or
something like this
3. Using Driver "rendition" which should be appropriate for the video card
(Diamond Stealth S220) causes this error message:

Symbol xf86SetDDCproperties from module
/usr/X11R6/lib/modules/drivers/rendition_drv.o is unresolved!

I think the problem is caused by broken rendition driver, as stated in the bug
377 in the bugzilla on xfree86.org. This bug was fixed.

Version-Release number of selected component (if applicable):

4.3.0-2

How reproducible:

use video card Diamond Stealth S220 (PCI)

Steps to Reproduce:
1. Install RH9 from CD in graphical mode.
or
1. Configure card to use rendition driver
    
Actual results:

X doesn't start, installation freezes.

Expected results:

X working, installation working.

Additional info:

see bug 377 on bugs.xfree86.org
Comment 1 Mike A. Harris 2003-10-31 06:33:34 EST
Ok, I read the upstream bug report, and I've generated a unified diff
of the driver between 4.3.0 and current.  Doing a quick review of all driver
changes seems to show most of them are purely cosmetic, and the non-cosmetic
changes seem likely to be safe to apply to our 4.3.0 packages.  Since this
hardware is very ancient and few users are probably using it, I see no harm 
in updating the driver to the current one.

At least that way if users have problems with the rendition driver and they
report them to http://bugs.xfree86.org, they actually stand a chance of
getting investigated and fixed.  Older hardware which is being used with
older X servers and older drivers tends to be ignored in bug reports.

The 4.3.0-43 build for Fedora Core will have this fix.  I may or may not
be able to squeeze it into RHL 9 erratum currently.  If you need an updated
driver for RHL 9 immediately however, I can put one on my ftp space for you
if you like.  Just let me know.



Comment 2 Mike A. Harris 2003-10-31 06:45:54 EST
Just an additional note that the rawhide XFree86 rendition driver has
had a SEGV bugfix related to DDC for quite a while now, which may or may
not have also worked around this problem.  Thought I'd mention that for
completeness as I just noticed I had added a rendition bugfix before and
forgotten about it.

The new CVS driver backport is now in my latest internal development package.
Comment 3 Robert Prewitt 2003-11-03 03:06:21 EST
Thanks for your immediate help! Please put the updated driver on your
ftp if it is possible, i am really in need of it.
Comment 4 Mike A. Harris 2003-11-10 09:05:01 EST
Here is the new driver.  Please update the bug report to let me know
wether it works for you or not.

ftp://people.redhat.com/mharris/rendition/rendition_drv.o

Thanks in advance.
Comment 5 Robert Prewitt 2003-11-12 04:34:51 EST
I tried the new driver on RH9 and FC1 and it works fine on both. There
is possibely a problem with monitor probing, i needed to put a
modeline by hand to obtain refresh rate higher than 60Hz - but i think
it is OK for such old and probably rare videocard. 
Fedora installation works (if nofb used), but after reboot X does not
start because of usining driver "vga" - so if you have the same or
similar videocard as i have (Diamond Stealth S220, rendition 2100
chip),  replace the fedora rendition_drv.o driver by the new one
linked above and change driver to "rendition" in XF86Config. It works
for RH9 too.
Comment 6 Jay Turner 2004-01-16 11:58:37 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-406.html

Note You need to log in before you can comment on or make changes to this bug.