Bug 1087628 - Hosts: "." in the name is invalid - user is told this but the UI adds one anyway.
Summary: Hosts: "." in the name is invalid - user is told this but the UI adds one any...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: jmagen@redhat.com
QA Contact: Elyézer Rezende
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
: 1101543 1103320 1103883 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-14 21:09 UTC by Corey Welton
Modified: 2016-04-22 14:52 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-07-02 14:06:43 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 5834 None None None 2016-04-22 14:52 UTC

Description Corey Welton 2014-04-14 21:09:15 UTC
Description of problem:
When user begins creating a host, enters a string in the Name field, and submits, they are told "must not include periods and is invalid".  It turns out the UI itself is adding this "."!

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140404.0

How reproducible:


Steps to Reproduce:
1.  Hosts > New Host
2.  for Name, enter the value "abcdef"
3.  Hit the submit button (yes, obv. there are other things that need to get filled out to create a host, but inconsequential for this test)
4. View results.

Actual results:
error message: "must not include periods and is invalid"
sure enough, a "." is added to the end of the string (it reads "abcdef."

Expected results:
No extraneous "."!

Additional info:
Occurs in Chrome and FF.

Comment 2 Dominic Cleal 2014-05-20 16:25:00 UTC
Created redmine issue http://projects.theforeman.org/issues/5834 from this bug

Comment 3 jmagen@redhat.com 2014-05-22 07:38:08 UTC
fixed in https://github.com/theforeman/foreman/pull/1464

Comment 4 Dominic Cleal 2014-05-27 13:41:57 UTC
*** Bug 1101543 has been marked as a duplicate of this bug. ***

Comment 5 Dominic Cleal 2014-06-02 07:08:45 UTC
*** Bug 1103320 has been marked as a duplicate of this bug. ***

Comment 6 Dominic Cleal 2014-06-03 06:58:46 UTC
*** Bug 1103883 has been marked as a duplicate of this bug. ***

Comment 7 Bryan Kearney 2014-06-06 15:54:13 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/5834 has been closed

Comment 10 Elyézer Rezende 2014-06-12 12:53:28 UTC
Verified:

1. Hosts > New Host
2. for Name, entered "abcdef"
3. Hit the submit button
4. The previous entered Name is the same

Environment:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.16-1.el6sat.noarch
* foreman-compute-1.6.0.16-1.el6sat.noarch
* foreman-gce-1.6.0.16-1.el6sat.noarch
* foreman-libvirt-1.6.0.16-1.el6sat.noarch
* foreman-ovirt-1.6.0.16-1.el6sat.noarch
* foreman-postgresql-1.6.0.16-1.el6sat.noarch
* foreman-proxy-1.6.0.7-1.el6sat.noarch
* foreman-selinux-1.6.0-4.el6sat.noarch
* foreman-vmware-1.6.0.16-1.el6sat.noarch
* katello-1.5.0-25.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.48-1.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.20.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.20.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.20.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.20.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.20.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.20.beta.el6sat.noarch
* pulp-server-2.4.0-0.20.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* rubygem-hammer_cli-0.1.1-4.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-9.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-2.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.4-6.el6sat.noarch

Comment 11 Bryan Kearney 2014-07-02 14:06:43 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.