Bug 108765 - redhat-logviewer does not start -- missing item in config file?
redhat-logviewer does not start -- missing item in config file?
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: redhat-logviewer (Show other bugs)
8.0
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
David Lawrence
:
: 108766 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-01 05:59 EST by Beat Steiner
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 09:49:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config file (966 bytes, text/plain)
2003-11-01 06:01 EST, Beat Steiner
no flags Details

  None (edit)
Description Beat Steiner 2003-11-01 05:59:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20030716

Description of problem:

I just downloaded logviewer from rawhide and 
installed it over a RH8.0 distro using
rpm -Uvh redhat-logviewer-0.9.3-4.noarch.rpm

When I try to start, the error pasted into "Actual Results"
appears.

According to previous bug reports, an item might be missing in the
config file (viewToSet). The following info may be relevant to you:

# echo $LANG
en_US.UTF-8


# cat /etc/sysconfig/redhat-logviewer
pasted into "Additional Information"

Thanks for helping

-- Beat

Version-Release number of selected component (if applicable):
redhat-logviewer-0.9.3-4.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
RH8.0 distro
rpm -Uvh redhat-logviewer-0.9.3-4.noarch.rpm
redhat-logviewer

Actual Results:  
# redhat-logviewer
Traceback (most recent call last):
  File "/usr/share/redhat-logviewer/redhat-logviewer.py", line 80, in ?
    LogViewerGui.LogViewerGui(width,height, allowConfigChanges,
configFile,initialView)
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 265, in
__init__
    logFileView.set_cursor(logFilesListStore.get_path(viewToSet),
None, gtk.FALSE)
TypeError: GtkTreeView.set_cursor() argument 2 must be
gtk.TreeViewColumn, not None


Additional info:

# Configuration File for Red Hat Log Viewer
# Copyright (c) 2001-2003 Red Hat, Inc. all rights reserved.
# Copyright (c) 2001-2003 Tammy Fox <tfox@redhat.com>

# Log file names
SYSLOG=/var/log/messages
SECURELOG=/var/log/secure
MAILLOG=/var/log/maillog
CRONLOG=/var/log/cron
NEWSLOG=/var/log/spooler
BOOTLOG=/var/log/boot.log
CIPELOG=/var/log/cipe.log
DMESGLOG=/var/log/dmesg
HTTPDACCESSLOG=/var/log/httpd/access_log
HTTPDERRORLOG=/var/log/httpd/error_log
MYSQLLOG=/var/log/mysqld.log
RPMLOG=/var/log/rpmpkgs
TUXLOG=/var/log/tux
UP2DATELOG=/var/log/up2date
FTPLOG=/var/log/vsftpd.log
XFREE86LOG=/var/log/XFree86.0.log

# How often to refresh messages, in seconds
# If set below 30 seconds, it defaults to 30 seconds
REFRESHRATE=30

## Words to show alert icon for
## Comma-delimited list, not case-sensitive
ALERTWORDS=fail,denied,rejected,oops,segfault,segmentation

## Words to show warning icon for
## Comma-delimited list, not case-sensitive
WARNINGWORDS=warn
Comment 1 Beat Steiner 2003-11-01 06:01:03 EST
Created attachment 95644 [details]
Config file
Comment 2 Tammy Fox 2003-11-02 22:08:16 EST
*** Bug 108766 has been marked as a duplicate of this bug. ***
Comment 3 Tammy Fox 2004-04-15 15:25:08 EDT
I wasn't ever able to duplicate this error. I just tried it with the
latest version of system-logviewer with your config file, and it works
for me. Are you still seeing this error?
Comment 4 Paul Nasrat 2004-11-04 09:49:21 EST
Closing due to lack of activity and RH8 no longer supported

Note You need to log in before you can comment on or make changes to this bug.