Bug 10891 - gcc in prc-tools has incorrect search paths compiled into it.
Summary: gcc in prc-tools has incorrect search paths compiled into it.
Status: CLOSED DUPLICATE of bug 10179
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: prc-tools   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: bero
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-18 14:33 UTC by Rick Richardson
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-18 14:35:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Makefile showing overrides needed (929 bytes, text/plain)
2000-04-18 14:34 UTC, Rick Richardson
no flags Details

Description Rick Richardson 2000-04-18 14:33:23 UTC
The search paths compiled into gcc in prc-tools are completely wrong.
Check this out:

$ /usr/bin/m68k-palmos-coff-gcc -print-search-dirs
install:
/var/tmp/prc-tools-buildroot/usr/lib/gcc-lib/m68k-palmos-coff/2.7.2.3-kgpd-071097/
programs:
/var/tmp/prc-tools-buildroot/usr/lib/gcc-lib/m68k-palmos-coff/2.7.2.3-kgpd-071097/:/var/tmp/prc-tools-buildroot/usr/lib/gcc-lib/m68k-palmos-coff/:/usr/lib/gcc/m68k-palmos-coff/2.7.2.3-kgpd-071097/:/usr/lib/gcc/m68k-palmos-coff/:/var/tmp/prc-tools-buildroot/usr/m68k-palmos-coff/bin/m68k-palmos-coff/2.7.2.3-kgpd-071097/:/var/tmp/prc-tools-buildroot/usr/m68k-palmos-coff/bin/
libraries:
/var/tmp/prc-tools-buildroot/usr/lib/gcc-lib/m68k-palmos-coff/2.7.2.3-kgpd-071097/:/usr/lib/gcc/m68k-palmos-coff/2.7.2.3-kgpd-071097/:/var/tmp/prc-tools-buildroot/usr/m68k-palmos-coff/lib/m68k-palmos-coff/2.7.2.3-kgpd-071097/:/var/tmp/prc-tools-buildroot/usr/m68k-palmos-coff/lib/

Yow! searching /var/tmp/... !!!!!!!  But nowhere is it searching the
correct locations!  This results in having to use multiple -B options in
order to override the broken search paths in order to find the various
compiler passes.

email me at rick@remotepoint.com (NOTE new email address) and I can send
you a helloworld.c and a Makefile that you can use to test the installation
of prc-tools before you ship it.

-Rick Richardson (rick@remotepoint.com)

Comment 1 Rick Richardson 2000-04-18 14:34:59 UTC
Created attachment 206 [details]
Makefile showing overrides needed

Comment 2 Bernhard Rosenkraenzer 2000-08-09 08:18:19 UTC

*** This bug has been marked as a duplicate of 10179 ***


Note You need to log in before you can comment on or make changes to this bug.