Bug 1089278 - Mono 3.4
Summary: Mono 3.4
Status: CLOSED DUPLICATE of bug 1221559
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact:
URL:
Whiteboard: ChangeAcceptedF21 SystemWideChange
Keywords:
: 1146495 (view as bug list)
Depends On: 1089426 1220138
Blocks: openra mono-nat fuzzynet
TreeView+ depends on / blocked
 
Reported: 2014-04-18 11:57 UTC by Jaroslav Reznik
Modified: 2015-05-28 11:10 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-05-28 11:10:16 UTC
pbokoc: fedora_requires_release_note-


Attachments (Terms of Use)

Description Jaroslav Reznik 2014-04-18 11:57:02 UTC
This is a tracking bug for Change: Mono 3.4
For more details, see: http://fedoraproject.org//wiki/Changes/Mono_3.4

Update the Mono stack in Fedora from 2.10 to 3.4

Comment 1 Etienne CHAMPETIER 2014-04-19 07:21:33 UTC
Hi,

just a warning, don't use the mono-3.4.0 tag, use mono-3.4.0-branch.
For exemple this patch (https://github.com/mono/mono/commit/75c5d4a6c5256c31a129f458cae7846a0f0c02ab, cherry picked from https://github.com/mono/mono/commit/2f710f7ac8fad487c1671a8bf99f5658924155bd) correct number formatting and multithreading (same number formatted 3 times you can end up with 3 different string), which is used in npgsql, so if the result string isn't outofbound, you can corrupt your db.

You've been warned :)

Comment 2 Jaroslav Reznik 2014-07-04 10:43:30 UTC
This message is a reminder that Fedora 21 Accepted Changes Freeze Deadline is on 2014-07-08 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Freeze.

This bug should be set to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jreznik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/21/Schedule

Comment 3 Jaroslav Reznik 2014-10-07 12:23:35 UTC
This message is a reminder that Fedora 21 Change Checkpoint: 100% Code Complete Deadline (Former Accepted Changes 100% Complete) is on 2014-10-14 [1].

All Accepted Changes has to be code complete and ready to be validated in the Beta release (optionally by Fedora QA). Required bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a point of contingency plan. All incompleted Changes will be reported to FESCo on 2014-10-15 meeting. In case of any questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/21/Schedule

Comment 4 Jaroslav Reznik 2014-10-13 16:07:19 UTC
I don't see Mono 3.4 in Koji, also did not get any updates from change owners so far - removing from Fedora 21 changes set. Please, reopen if this change is still being worked on - just a reminder, Change deadline is tomorrow.

Comment 5 Petr Bokoc 2014-10-14 12:14:44 UTC
Setting release notes flag to - for F21.

(The wiki page also lists target release: F22.)

Comment 6 Raphael Groner 2015-02-01 12:13:11 UTC
Mono.NAT is nearly dead with no obviously current master branch.

Open:NAT is the new hope but needs Mono 3 cause of .NET 4.5 interface.

+1 for this enhancement, asap please :)

Comment 7 Raphael Groner 2015-02-03 20:48:28 UTC
*** Bug 1146495 has been marked as a duplicate of this bug. ***

Comment 8 Jaroslav Reznik 2015-03-03 15:43:09 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 9 Raphael Groner 2015-05-28 07:54:44 UTC
 Current status

    Targeted release: Fedora 23
    Last updated: May 20, 2015 

Setting to rawhide for now, cause there's no f23 branch currently.

Comment 10 Timotheus Pokorra 2015-05-28 08:15:05 UTC
Has this bug been superseded by https://bugzilla.redhat.com/show_bug.cgi?id=1221559 "Mono 4"?

I think most packages will work fine with Mono4, without much effort (just switching to .net 4.5 target framework).

Or are there other reasons to provide two Mono versions (3.4 and 4.0) for f23?

Comment 11 Claudio Rodrigo Pereyra DIaz 2015-05-28 11:10:16 UTC

*** This bug has been marked as a duplicate of bug 1221559 ***


Note You need to log in before you can comment on or make changes to this bug.