Bug 1089426 - Fedora's version of Mono is horrendously outdated with lots of vulns. [fedora-all]
Summary: Fedora's version of Mono is horrendously outdated with lots of vulns. [fedora...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mono
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavier Lamien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1164015 (view as bug list)
Depends On:
Blocks: CVE-2015-2318, CVE-2015-2319, CVE-2015-2320 226158 839978 853110 1089278 1128499 openra mono-nat fuzzynet 1220138
TreeView+ depends on / blocked
 
Reported: 2014-04-18 22:50 UTC by Georgiy Treyvus
Modified: 2018-04-11 10:34 UTC (History)
19 users (show)

Fixed In Version: mono-4.0.1-7.fc23
Doc Type: Release Note
Doc Text:
Clone Of:
: 1220138 (view as bug list)
Environment:
Last Closed: 2015-11-04 11:17:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1221559 None CLOSED Mono 4 2019-01-15 09:12:14 UTC

Internal Links: 1221559

Description Georgiy Treyvus 2014-04-18 22:50:30 UTC
Debian stable literally has newer versions of both Mono and especially MonoDevelop. Don't even get me started on testing and unstable...

Comment 1 Chris Morgan 2014-05-21 22:03:55 UTC
Yeah, the 3.x series has been out for a couple of years now. It would be nice to jump up to the latest release for F21.

Comment 2 Mike 2014-07-17 13:03:14 UTC
I also desperately need a more current mono version. I need this mainly for arm platform (RasPI, pidora).

Comment 3 J. Thiem 2014-11-25 19:02:03 UTC
The open-source game OpenRA (http://openra.net/) runs into issues which the devs told me are most likely due to the old mono version.

Is mono for Fedora still actively maintained?

Comment 4 scattol 2014-12-26 22:39:46 UTC
I need it for Repetier 1.06 http://www.repetier.com/downloads/

Comment 5 Moez Roy 2015-02-06 16:51:20 UTC
*** Bug 1164015 has been marked as a duplicate of this bug. ***

Comment 6 Jaroslav Reznik 2015-03-03 15:43:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 7 Rex Dieter 2015-04-01 13:22:34 UTC
marking rawhide/FutureFeature, to avoid autoclose/auto-rebase of the bug

Comment 8 Moez Roy 2015-04-01 15:03:20 UTC
mono-core-3.12.1-0.src.rpm from http://download.mono-project.com/repo/centos/SRPMS/ built successfully for F21: https://koji.fedoraproject.org/koji/taskinfo?taskID=9392781

It failed against rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=9392925

Comment 9 Raphael Groner 2015-04-01 15:45:20 UTC
(In reply to Moez Roy from comment #8)

Is the recent build failure related to that patch?
http://static-173-79-223-25.washdc.fios.verizon.net/?l=mono-patches&m=138211276301187&q=raw

Comment 10 Raphael Groner 2015-04-01 15:49:36 UTC
Maybe also …
https://groups.google.com/forum/#!topic/mono-svn-patches/qQrKoyt-j9A

Should undefine HAVE_KW_THREAD?
https://marc.info/?l=mono-patches&m=124571096012427

This is what Google gives me as helpfully looking links so far.

Comment 11 Moez Roy 2015-04-03 12:11:27 UTC
(In reply to Raphael Groner from comment #9)
> (In reply to Moez Roy from comment #8)
> 
> Is the recent build failure related to that patch?
> http://static-173-79-223-25.washdc.fios.verizon.net/?l=mono-
> patches&m=138211276301187&q=raw

(In reply to Raphael Groner from comment #10)
> Maybe also …
> https://groups.google.com/forum/#!topic/mono-svn-patches/qQrKoyt-j9A
> 
> Should undefine HAVE_KW_THREAD?
> https://marc.info/?l=mono-patches&m=124571096012427
> 
> This is what Google gives me as helpfully looking links so far.

I have no clue.

I am not motivated enough to look more into this right now.

Can you try and see if you can build it for rawhide?

Comment 12 Raphael Groner 2015-04-07 14:15:31 UTC
Mono 4.0.0 Release Notes:
"We no longer build or package reference assemblies for the .NET 2.0, .NET 3.5 or .NET 4.0 APIs. We only support now the .NET 4.5 assemblies as well as the mobile-based profiles."

http://www.mono-project.com/docs/about-mono/releases/4.0.0/

What's the strategical plan in Fedora?

Comment 13 Timotheus Pokorra 2015-04-10 06:31:02 UTC
(In reply to Moez Roy from comment #8)

It seems that Mono 4.0 Alpha1 builds fine on Rawhide:
https://copr.fedoraproject.org/coprs/elsupergomez/mono-4/build/85185/

I tried to find the difference in the Mono github repository, but was not able to find it.
mono/mini/mini.c has been split, and the function mono_get_jit_tls_offset now lives in
https://github.com/mono/mono/blob/master/mono/mini/mini-runtime.c#L674
but still looks the same as in 3.12.1:
https://github.com/mono/mono/blob/mono-3.12.1/mono/mini/mini.c#L2638

Comment 14 Raphael Groner 2015-09-22 17:50:21 UTC
Mono 4 is now in Fedora 23 Beta, see official announcement.

Can we so close this bug as a duplication of bug #1221559 ?

Comment 15 Claudio Rodrigo Pereyra DIaz 2015-09-24 16:25:51 UTC
(In reply to Raphael Groner from comment #14)
> Mono 4 is now in Fedora 23 Beta, see official announcement.
> 
> Can we so close this bug as a duplication of bug #1221559 ?

Maybe close as Next Release ? is another option.

Comment 16 Peter Robinson 2015-11-04 11:17:52 UTC
I'm going to close this, IMO it's too evasive to push back to F-22, F-21 will be EOL in around a month. Those that wish to use mono are strongly advised to upgrade to Fedora 23 which is now GA.


Note You need to log in before you can comment on or make changes to this bug.