Bug 1089505 - incorrect service file
Summary: incorrect service file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nsd
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1096049 1118976 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-19 23:03 UTC by Michael S.
Modified: 2014-08-08 08:38 UTC (History)
5 users (show)

Fixed In Version: nsd-3.2.18-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 08:37:45 UTC


Attachments (Terms of Use)

Description Michael S. 2014-04-19 23:03:02 UTC
nsd do not start anymore on fedora 20

# /usr/sbin/nsd -D -c /etc/nsd/nsd.conf $OTHER_NSD_OPTS
/usr/sbin/nsd: invalid option -- 'D'


# grep -- -D  /usr/lib/systemd/system/nsd.service 
ExecStart=/usr/sbin/nsd -D -c /etc/nsd/nsd.conf $OTHER_NSD_OPTS

Comment 1 Michael S. 2014-04-19 23:08:34 UTC
A workaround :

$ cat /etc/systemd/system/nsd.service.d/fix_1089505.conf
[Service]
ExecStart=
ExecStart=/usr/sbin/nsd -c /etc/nsd/nsd.conf $OTHER_NSD_OPTS

+ systemctl daemon-reload

Comment 2 Paul Wouters 2014-07-28 14:29:57 UTC
*** Bug 1096049 has been marked as a duplicate of this bug. ***

Comment 3 Paul Wouters 2014-07-28 14:30:35 UTC
*** Bug 1118976 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2014-07-28 15:34:24 UTC
nsd-3.2.18-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/nsd-3.2.18-1.fc20

Comment 5 Fedora Update System 2014-07-28 15:34:54 UTC
nsd-3.2.18-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nsd-3.2.18-1.fc19

Comment 6 Fedora Update System 2014-07-30 07:02:47 UTC
Package nsd-3.2.18-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nsd-3.2.18-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9006/nsd-3.2.18-1.fc19
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-08-08 08:37:45 UTC
nsd-3.2.18-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-08-08 08:38:05 UTC
nsd-3.2.18-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.