Bug 108954 - Resolution greater than 640X480 not possible.
Resolution greater than 640X480 not possible.
Status: CLOSED DUPLICATE of bug 120950
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-03 14:03 EST by Omar Ghanchi
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omar Ghanchi 2003-11-03 14:03:37 EST
Description of problem:

Monitor = IBM C2237 C71 17" Color Monitor
Video Card = ATI Radeon 7000
MSI Motherboard
Pentium 4 2.0GHz processor

When 1024 X 768 is selected it is so big that it doesn't fit the 
screen. It's out of bound. From the start when the installation 
enters the graphical mode, this problem is there. And when the 
installation is completed, the viewable area is too big to fit into 
my 17" monitor. The only way I can fit the screen is to select 
640X480 resolution.

The monitor type and the card type is picked up correctly by the 
install.
Have tried running XFree86 several times with several different 
monitor types, the problem still exists.
Have tried manually editing the XFConfig file, no help.
As soon as the boot enters the graphical mode, this problem pops up.

The monitor and video card work perfectly on XP, 2000, Redhat 8, and 
Mandrake 9.0, 9.2 installations.

Version-Release number of selected component (if applicable):
Fedora 0.95 Test 3 Release.


How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike A. Harris 2003-11-03 14:37:58 EST
This sounds like the config tool is not detecting the monitor
properly and/or isn't setting the proper H/V rates, and the
server is getting misconfigured, however the driver will start
up with the configured resolution set as the maximum virtual
size, with the physical resolution set to a smaller size which
is compatible with the monitor.

Please attach your X server config file and log file from the
non-working configuration.
Comment 2 Omar Ghanchi 2003-11-03 21:22:35 EST
Hi Mike:

Here are the monitor, video card and screen sections of the XF86Config
file from /etc/X11/

I am not sure about the log file. Can you point me to where this log
file might be?
***********************
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "IBM 2237 C71"
	HorizSync    30.0 - 69.0
	VertRefresh  50.0 - 120.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
	VendorName  "Videocard vendor"
	BoardName   "ATI Radeon 7000"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes    "800x600" "640x480"
	EndSubSection
EndSection
Comment 3 Need Real Name 2003-11-20 12:25:13 EST
I have this same problem, but it is will known that my Compaq evo
n600c Laptop docking station is the root cause. If I unplug my KDS
VS195 from the dock, boot-up, and then plug in the Monitor, all is ok
for the 1024x768 setting. (For RedHat.v.9.x and earlier, I could boot
up with the Laptop lid open, then close the lid, and the X-server
would configure the VS195 correctly.) jerry.laney@gm.com
Comment 4 Brent Rowse 2003-11-26 16:31:28 EST
I have the same problem with an ATI Radeon 7000 and a Mag Innovision
LT865b.  If I keep changing the monitor and video card types the
system will work correctly until the power is turned off.  When it
comes back up, the problem is back.
Comment 5 Omar Ghanchi 2003-12-13 17:00:11 EST
I think it's the new version of XFree86. I downloaded the new updates
of XFree86 on my RH9 install and the same problem appeared. However,
in dealing with this, I found that when the system booted, and RH or
Fedora started X, I have to swtich off my monitor and hit
Ctrl+Alt+Backspace. I wait a couple of seconds, and then switch the
monitor back on and everything is fine, until I log out again. Then I
have to switch the monitor off and then do the same thing again. It's
annoying, but at least it works now!

I even installed XFree86 from sources, but the problem persisted even
after that.
Comment 6 Benoit Hebert 2004-03-19 17:36:55 EST
I have the same problem here with a Dell PC, running on an Intel 865
video card with a Sun Microsystems GH18PS LCD monitor. No matter what
I put in as the display settings, the screen resolution remains locked
at 640x480.
Any idea when a solution will be available, or should I go back to an
earlier version of Red Hat?
Comment 7 Claudio 2004-04-28 16:55:00 EDT
I found the same problem with my ATI 7500 and Sony CPD 200ES. The
system-config-display have add a comment in the file config (xorg.conf) :

### Uncomment if you don't want to default to DDC:
 ### Uncomment if you don't want to default to DDC:
#	HorizSync    30.0 - 70.0
#	VertRefresh  50.0 - 120.0
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Sony CPD-200ES"
	DisplaySize  330	240
 ### Uncomment if you don't want to default to DDC:
#	HorizSync    30.0 - 70.0
#	VertRefresh  50.0 - 120.0
	Option	    "dpms"
EndSection

I have removed the commenet here: 
	HorizSync    30.0 - 70.0
	VertRefresh  50.0 - 120.0

in the xorg.conf file and restarted the server. The resolution restart 
 at 1024/768 and now i can change res and frequency.


Comment 8 Alex Markley 2004-05-02 18:56:52 EDT
Hi. I just installed fedora core 2 test 3 and had a problem similar to
this one. My hardware is: radeon 9000 pro video chipset and NCD
NC1982AA monitor.

Whenever the X Server started, the log file would show it rejecting
all resolutions above 640x480 because "HSync out of range".

I fixed it by manually adjusting the refresh rates in the
/etx/X11/Xorg.conf file. I could not resolve the problem using the
supplied GUIs.

Hope this helps
--Alex
Comment 9 Karl Auerbach 2004-05-03 16:44:43 EDT
I'm experiencing the same kind of problem:

Chipset: Intel 810 (Intel 82810E) (un an old Dell GX110) and Sony 
E400 monitor.

In the display configuration tool ("system settings" | "display") it 
shows the correct hardware, and if I say "OK" to either the monitor 
or card it even shows me optional resolution and color depth values.  
But the new settings have no effect and revert to the 640x480.  
Restarting X doesn't help either.

The machine worked fine under Fedora 1.  (Fedora 2 was a full 
install, not an upgrade.)
Comment 10 Naraki 2004-05-11 11:14:07 EDT
yup Ive got the same problem on a Gforce 4ti se 4800 on a eizo f56 I
cant resize to resolutions above 640x480. manually editing the
/etc/X11/XF86config.conf file didnt help editing the Xorg.conf didnt
help eighter editing the Vsync and Hsync I havent tryed yet it was a
full install and the latest Nvidia drivers were used < no source but
.run > 

is there currently a workaround available ?
Comment 11 Mike A. Harris 2004-05-11 19:04:36 EDT

*** This bug has been marked as a duplicate of 120950 ***
Comment 12 Omar Ghanchi 2004-05-26 19:02:18 EDT
I started this bug report and have the same issue since FC1. The
problem still exists in FC2.

My workaround is as follows:

Once you get the log on screen, turn the monitor off.
Then do Control+Alt+Backspace.
Wait for a few seconds (5 seconds)
Then turn the monitor on.
The resolution will fit the screen perfectly.

I hope this helps.

Omar.
Comment 13 Red Hat Bugzilla 2006-02-21 13:59:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.