Bug 108960 - postfix has a bug preventing use with (among others) MH, pine
Summary: postfix has a bug preventing use with (among others) MH, pine
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
: 110671 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-03 19:56 UTC by Sjoerd Mullender
Modified: 2007-11-30 22:10 UTC (History)
5 users (show)

Fixed In Version: postfix-2.0.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-18 17:45:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:409 normal SHIPPED_LIVE Updated postfix package resolves MUA-related mail sending failures 2004-05-12 04:00:00 UTC

Description Sjoerd Mullender 2003-11-03 19:56:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a)
Gecko/20031101 Firebird/0.7+

Description of problem:
A bug was introduced in version 2.0.11 of postfix and fixed in version
2.0.12.  The description of the fix is:
Bugfix: the stricter postdrop input filter broke "sendmail -bs". Found
by Lutz Jaenicke. File: smtpd/smtpd.c.

This bug manifests itself with the error message
fatal: uid=XXX: unexpected record type: 84
and the refusal to send the message.

The problem is in the interaction between smtpd and postdrop, both of
which are started by sendmail.  Smtpd sends a timestamp to postdrop
which postdrop doesn't expect.  Postdrop then produces the error
message and exits.

Please update postfix to a newer version.

Version-Release number of selected component (if applicable):
2.0.11-5

How reproducible:
Always

Steps to Reproduce:
1.Send a message with MH or pine configured to use the local postfix
installation.
2.
3.
    

Additional info:

Comment 1 Justin Mason 2003-11-12 00:12:25 UTC
yes, I'm seeing this too. :(

also reproducible by using the same protocol as nmh's "post" command,
as follows (SMTP commands are me btw):

$ /usr/lib/sendmail -bs -odb -oem -om
220 jmason.org ESMTP Postfix
MAIL FROM:<jm@jmason.org>
250 Ok
RCPT TO:<jm@dogma.slashnull.org>
250 Ok
DATA
From: <jm@jmason.org>
To: <jm@dogma.slashnull.org>
Subject: tseting

foo
.
354 End data with <CR><LF>.<CR><LF>
postdrop: fatal: uid=500: unexpected record type: 84
451 Error: queue file write error
QUIT
221 Bye
$

Comment 2 Justin Mason 2003-11-12 00:13:35 UTC
oh, btw, come to think of it I may have set up the /usr/lib/sendmail
symlink myself.  It's a symlink to /etc/alternatives/mta, identical to
/usr/sbin/sendmail.

Comment 3 John Dennis 2003-11-17 20:39:54 UTC
I have built a new rpm from the 2.0.16 postfix source, I have not the
opportunity to test it because of other demands and I don't want this
to drag out, I'm sorry. To expedite the update process I would
encourage those of you with an interest in this bug to try testing the
following rpm and give me some feedback

ftp://people.redhat.com/jdennis/postfix-2.0.16-1.i386.rpm

Thanks,

John

Comment 4 Sjoerd Mullender 2003-11-17 23:24:06 UTC
I can't install this rpm because it depends on libcom_err.so.3 which I
don't have installed and can't find on the Fedora Core 1 CDs.

Comment 5 Justin Mason 2003-11-17 23:54:07 UTC
Me too, I'm afraid.  

Comment 6 John Dennis 2003-11-18 15:19:55 UTC
I rebuilt the rpm using the official fedora environment and replaced
it on the ftp site, this should resolve the dependency problem you
encountered. Give it a go, my apologies for a false start.

Comment 7 Sjoerd Mullender 2003-11-18 17:04:09 UTC
This seems to fix the bug.

Comment 8 Justin Mason 2003-11-18 17:42:12 UTC
yep, works for me too. thanks!

Comment 9 John Dennis 2003-11-18 17:45:28 UTC
Thank you Sjoerd and Justin! Your help is appreciated. I am going to
close the bug and push the new package through the fedora update process.

Comment 10 John Dennis 2003-11-24 14:42:50 UTC
*** Bug 110671 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.