Bug 110671 - postfix sendmail's version may be incompatible
Summary: postfix sendmail's version may be incompatible
Status: CLOSED DUPLICATE of bug 108960
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix   
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-22 17:45 UTC by Henrique Martins
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrique Martins 2003-11-22 17:45:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Upgrading from RH9 to Fedora broke nmh's send capability.  On mailog
the error is of the form:
  postfix/postdrop[XXXX]: fatal: uid=XXX: unexpected record type: 84 
according to these two web posts:
  http://archives.neohapsis.com/archives/postfix/2003-07/0443.html
  http://archives.neohapsis.com/archives/postfix/2003-07/0444.html
this is due to:
  You're using sendmail/postdrop commands
  from different Postfix versions. 

I was using postfix before upgrading and it worked.  I uninstalled
postfix (saving my configuration) did a find for any file named
*sendmail* and did not find anything important (some doc, perl and
emacs files were left).  I re-install Fedora's rpm and the error was
still there.

I then uninstalled Fedora's version one more time, downloaded version
postfix-2.0.16 from postfix.org and installed it.  Works fine.

Postfix seemed to work, just its sendmail interface which nmh expects
didn't

Version-Release number of selected component (if applicable):
postfix-2.0.11-5.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. install nmh
2. create a draft folder
3. try to send it
    

Actual Results:  Bounces back (from Emacs) fails from the command
line. One line like:
  postfix/postdrop[XXXX]: fatal: uid=XXX: unexpected record type: 84
is appended to /var/log/maillog

Expected Results:  send the message

Additional info:

Only made it fail with nmh.  Not sure whether invoking sendmail
directly will fail.

Comment 1 John Dennis 2003-11-24 14:42:49 UTC
This is a duplicate of bug 108960 which has been fixed. A new rpm is
being pushed through the Fedora update process, but that may take a
while, in the interim you may download a copy of the rpm from here:

ftp://people.redhat.com/jdennis/postfix-2.0.16-1.i386.rpm

*** This bug has been marked as a duplicate of 108960 ***

Comment 2 Henrique Martins 2003-11-24 17:16:25 UTC
Sorry for the duplicate! I only queried Fedora version 1, did not
include versions test1, test2 and test3 and thus didn't find 108960.

New rpm referenced there seems to fix my problem. Thanks.

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.