Bug 109012 - Up2date thinks kernel-2.4.21-4.0.1.EL isn't installed (sometimes).
Up2date thinks kernel-2.4.21-4.0.1.EL isn't installed (sometimes).
Status: CLOSED DUPLICATE of bug 108480
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
: 109966 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2003-11-04 07:06 EST by Ali-Reza Anghaie
Modified: 2007-11-30 17:06 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:59:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ali-Reza Anghaie 2003-11-04 07:06:10 EST
Description of problem:

up2date -l shows the kernel-2.4.21-4.0.1.EL errata available although
it's already installed. up2date --show-available does ~not~ show
kernel-2.4.21-4.0.1.EL as available. up2date interactice shows it but
won't install it once it checks for conflicts, because it's already

And up2date kernel-doc tried to all install kernel-2.4.21-4.0.1.EL as
a package until I did an up2date -p, then it only showed kernel-doc as

Buuuutttt... up2date -l still shows kernel-2.4.21-4.0.1.EL as well as
interactive. Although RHN does not show this as missing.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. up2date -l  &&  up2date --show-available
Actual results:

Still thinks kernel errata is not installed.

Expected results:

Stop bugging me about kernel errata.

Additional info:

The RHN applet also doesn't complain, it thinks the kernel is
installed. Just up2date -l and up2date interactive have this problem.
Comment 2 Ali-Reza Anghaie 2003-11-12 18:36:35 EST
Changing priority and severity. No matter what I do trying to use
up2date, once I remove the kernel exception (and since I run by hand
or schedule online, I want the exception removed) it now:

RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package kernel-2.4.21-4.0.1.EL is already installed

So I can't easily use up2date in a default fashion to update all the
errata packages on a system. I consider this a pain to maintainence of
any quantity of boxes we may deploy. Cheers, -Ali
Comment 3 Josef Komenda 2003-11-13 11:27:57 EST
*** Bug 109966 has been marked as a duplicate of this bug. ***
Comment 4 greyhair 2003-12-18 03:26:00 EST
check to see if kernel-2.4.21-4.EL is installed.
rpm -q kernel
if you do, remove kernel-2.4.21-4.EL  and you 
should not see the:

RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package kernel-2.4.21-4.0.1.EL is already installed
Comment 5 greyhair 2003-12-18 03:30:01 EST
Isn't bug 108480 simular?  Thats how I determined the work arround 
previously posted.
Comment 6 nathan r. hruby 2003-12-18 07:16:28 EST
Right, but the point is that you maybe don't want to remove the known
good working kernel :)  up2date *should* allow you to have multiple
kernel packages installed, the bug is that it doesn't (eg: the code is
in there, but it's broken :)
Comment 7 Adrian Likins 2003-12-18 13:47:24 EST
dupe of 108480.

Yes. It is a bug. Yes, a fix is coming. 

*** This bug has been marked as a duplicate of 108480 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:59:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.