Bug 109966 - RHN+up2date don't work the same w/ multiple kernels on RHEL3
RHN+up2date don't work the same w/ multiple kernels on RHEL3
Status: CLOSED DUPLICATE of bug 109012
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Stable
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 10:42 EST by Glen A. Foster
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2003-11-13 10:42:36 EST
Description of problem: This may NOT be an RHN issue and may lie
elsewhere -- feel free to forward as necessary.

With RHEL3, the kernel on the distro-media is 2.4.21-4.EL; soon after
the release of RHEL3 came the first kernel errata, which was the
2.4.21-4.0.1.EL -- so far, so good; looks like a "regular" distro. 
Typically I find I can run "up2date -u" to upgrade packages and then
run it _again_ to verify nothing new came in... and it usually tells
me "no new packages" the second time I run "up2date -u".

The problem with RHEL3 is that after running "up2date -u" (following a
call to rhn_register, of course) the SECOND time (e.g., the "did
anything new get posted?" check), an error message is thrown:

Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package kernel-2.4.21-4.0.1.EL is already installed

... this is new behavior.  IMO, the second "up2date -u" should simply
say "no new packages".

Version-Release number of selected component (if applicable):
# rpm -q kernel up2date
kernel-2.4.21-4.EL
kernel-2.4.21-4.0.1.EL
up2date-4.0.1-1

How reproducible: 100% (always)

Steps to Reproduce:
1. everything-install on RHEL3 (ia64 for sure, don't know about x86)
2. rhn_register
3. up2date -u # gets all the package updates
4. up2date -u # checks for new packages -- this one FAILS
Comment 1 Josef Komenda 2003-11-13 11:27:55 EST

*** This bug has been marked as a duplicate of 109012 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.