Bug 10919 - ipx_configure fails socket() call: "socket: invalid argument"
ipx_configure fails socket() call: "socket: invalid argument"
Status: CLOSED DUPLICATE of bug 10375
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-19 11:16 EDT by Richard Elkins
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-19 11:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Elkins 2000-04-19 11:16:53 EDT
We never tried Netware under 6.1.
and recently upgraded to 6.2.

Our goal:  Connect to an existing Netware printer as a client.

We manually loaded ncpfs.o with `insmod`
and tried to run ipx_configure.  The following message appeared:

   /sbin/ipx_configure: socket: Invalid argument

I created a small program with the same socket() call:

   s = socket(AF_IPX, SOCK_DGRAM, AF_IPX);

and got the same result from socket().

I upgraded the ncpfs RPM package but it was no help.

It seems like the AF_IPX family is missing from the Redhat 6.2 distribution
or the HOW-TOs are missing a step.

Please asist ASAP.
Comment 1 Bill Nottingham 2000-04-19 11:19:59 EDT
Grab the latest modutils from rawhide; it has the proper
alias for the ipx module.

Alternatively, run 'modprobe ipx' before trying to use
IPX software.

*** This bug has been marked as a duplicate of 10375 ***

Note You need to log in before you can comment on or make changes to this bug.