Bug 109212 - Detecting CPU type change and telling rpm
Summary: Detecting CPU type change and telling rpm
Status: CLOSED DUPLICATE of bug 112950
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-05 17:42 UTC by Daniel Veillard
Modified: 2014-03-17 02:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Veillard 2003-11-05 17:42:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I changed my motherboard from a Celeron to an Athlon.
When launching up2date after the fact I noted it was still
upgrading the kernel packages with i686.rpm instead of athlon.rpm
The kernel and I assume kudzu found the change but this wasn't
propagated to /etc/rpm/platform , as a result rpm/up2date/...
will not use the new patchform informations for upgrades.



Version-Release number of selected component (if applicable):
kidzup-1.1.35-1

How reproducible:
Didn't try

Steps to Reproduce:
1.upgrade your processor
2.launch up2date on kernel upgrade
3.see up2date using the older arch
    

Actual Results:  /etc/rpm/platform was kept as is.

Expected Results:  Ideally kudzu should keep /etc/rpm/platform up to
date on processor
changes.

Additional info:

Comment 2 Daniel Veillard 2004-09-16 08:57:13 UTC

*** This bug has been marked as a duplicate of 112950 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:59:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.