Bug 112950 - RFE: System update should check CPU architecture.
RFE: System update should check CPU architecture.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
All Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 109212 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-06 11:27 EST by Ivo Sarak
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-07 11:50:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2004-01-06 11:27:55 EST
Description of problem:
When to upgrade Fedora Core 1 on different machine with different 
machine architecture, Fedora Core 1 update will fail to detect the 
new architecture and will not upgrade/replace the kernel.

Version-Release number of selected component (if applicable):
Fedora Core 1.

How reproducible:
Always.

Steps to Reproduce:
1. Install FC1 on Athlon CPU machine;
2. Move the HDD to machine with i586 CPU machine;
3. As the Athlon kernel is unable to start up the machine, upgrade 
the system from the same FC1 media You installed it at the first 
place;
  
Actual results:
Kernel is not being upgraded/replaced and at the end You are still 
unable to start the system.

Expected results:
Kernel replaced and system running.

Additional info:
The box I put the "Athlon" HDD is VIA Samuel2 what is being 
classified as i586.

How do upgrade the box?
Comment 1 Jeremy Katz 2004-01-06 11:35:35 EST
The package version is the same and so it's not an upgrade. 

To workaround, you can originally install by booting with 'linux
rpmarch=i586' and it will assume that you're an i586 (should work, not
really tested or supported).
Comment 2 Ivo Sarak 2004-01-07 02:08:24 EST
Thanks, I'll try this.

But Your explanation about the package version as being the same has
some flaws. Why this kind of upgrade does upgrade 3 packages: xterm,
w3m and compat_db?

Why these are upgraded? And as these packages are upgraded to the same
version then why not add kernel to the same category?

If it still not classify as a bug then I'll add it as RFE.
Comment 3 Jeremy Katz 2004-01-07 11:50:21 EST
Because those packages got flagged as newer for some reason or
another.  An upgrade does not reinstall any packages and this is not
going to change.
Comment 4 Daniel Veillard 2004-09-16 04:57:26 EDT
*** Bug 109212 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.