Bug 1092414 - Disable NFS by default
Summary: Disable NFS by default
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: mainline
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.8.0
TreeView+ depends on / blocked
 
Reported: 2014-04-29 09:19 UTC by Marco Rodrigues
Modified: 2016-06-16 16:17 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 12:38:43 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Marco Rodrigues 2014-04-29 09:19:44 UTC
Description of problem:
If we run an NFS export already, the GlusterFS will conflict with it. In my case, I did first the GlusterFS volumes using FUSE and then IC had to set nfs.disable to ON on all the volumes one by one to be able to use an NFS export. Then I did it on all the cluster machines.

If we don't need it, why it needs to be activated by default ?

Comment 1 Niels de Vos 2014-09-09 07:45:51 UTC
We'll think about disabling NFS by default for 3.7. This is not something we can change in current releases.

Comment 2 Niels de Vos 2015-06-01 09:50:42 UTC
The plan is to make Gluser/NFS an optional component for Gluster 4.0. If the Gluster/NFS bits are not installed, NFS will obviously not be enabled either.

There are too many 3.x users that expect Gluster/NFS to be enabled by default, it is not something we can change without confusing those users.

Comment 3 Vijay Bellur 2015-10-29 16:19:59 UTC
REVIEW: http://review.gluster.org/12463 ([WIP] glusterd: make Gluster/NFS an optional component) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 4 Niels de Vos 2016-04-12 08:06:21 UTC
We've decided to turn Gluster/NFS off by default for GlusterFS 3.8. The Gluster/NFS server will most likely not be an optional component, this is targeted for Gluster 4.0.

Comment 5 Vijay Bellur 2016-04-12 11:47:21 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#19) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 6 Vijay Bellur 2016-04-14 11:48:41 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#20) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 7 Vijay Bellur 2016-04-14 12:09:27 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#21) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 8 Vijay Bellur 2016-04-14 13:06:35 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#22) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 9 Vijay Bellur 2016-04-14 15:31:21 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#23) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 10 Vijay Bellur 2016-04-15 23:10:26 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#24) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 11 Vijay Bellur 2016-04-19 14:36:35 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#25) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 12 Vijay Bellur 2016-04-20 01:52:33 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#26) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 13 Vijay Bellur 2016-04-20 11:17:42 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#27) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 14 Vijay Bellur 2016-04-22 01:24:34 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#28) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 15 Vijay Bellur 2016-04-23 11:30:13 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#29) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 16 Vijay Bellur 2016-04-24 23:50:06 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#30) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 17 Vijay Bellur 2016-04-25 15:57:02 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#31) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 18 Vijay Bellur 2016-04-26 16:27:47 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#32) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 19 Vijay Bellur 2016-04-26 16:36:45 UTC
REVIEW: http://review.gluster.org/13738 (glusterd: default value of nfs.disable, change from false to true) posted (#33) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 20 Vijay Bellur 2016-04-27 07:59:33 UTC
COMMIT: http://review.gluster.org/13738 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit a4f84d786b596387aa0d659fb5cc8a933c95c01b
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Tue Mar 15 06:16:31 2016 -0400

    glusterd: default value of nfs.disable, change from false to true
    
    Next step in eventual deprecation of glusterfs nfs server in favor
    of ganesha.nfsd.
    
    Also replace several open-coded strings with constant.
    
    Change-Id: If52f5e880191a14fd38e69b70a32b0300dd93a50
    BUG: 1092414
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13738
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 21 Vijay Bellur 2016-04-28 12:08:07 UTC
REVIEW: http://review.gluster.org/14105 (glusterd: default value of nfs.disable, change from false to true) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 22 Vijay Bellur 2016-04-28 12:21:23 UTC
REVIEW: http://review.gluster.org/14105 (glusterd: default value of nfs.disable, change from false to true) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 23 Vijay Bellur 2016-04-28 20:45:24 UTC
COMMIT: http://review.gluster.org/14105 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 04d57237099fefa3a92a0cca4c65e43f39c13379
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Thu Apr 28 08:05:29 2016 -0400

    glusterd: default value of nfs.disable, change from false to true
    
    revert gf_msg -> gf_msg_plain change, i.e. restore gf_msg()
    
    Change-Id: Ibdf9906c8a4bf92ba0969a08bb5a5c01dfd74680
    BUG: 1092414
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/14105
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 24 Niels de Vos 2016-06-16 12:38:43 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 25 Niels de Vos 2016-06-16 16:17:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.