Bug 1317278 - (glusterfs-3.8.0) GlusterFS 3.8.0 tracker
GlusterFS 3.8.0 tracker
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
3.8.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Niels de Vos
https://www.gluster.org/community/roa...
: Tracking, Triaged
Depends On: 1092414 1220173 1290766 1303829 1326085 1326308 1327174 1331704 1332162 1332788 1332839 1334268 1334836 1335017 1337130 1337387 1337596 1337638 1337805 1338501 1340487 1340935 1341556 1342350 1344421 1345713 1346222
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 13:37 EDT by Niels de Vos
Modified: 2016-06-16 12:18 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: glusterfs-3.8.1 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:18:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2016-03-13 13:37:38 EDT
This bug is used for tracking the progress of Gluster 3.8 features. Each feature on the roadmap [1] is expected to have one (main tracker) bug blocking this 'glusterfs-3.8.0' tracker.


1. https://www.gluster.org/community/roadmap/3.8/
Comment 1 Vijay Bellur 2016-05-16 07:19:57 EDT
REVIEW: http://review.gluster.org/14359 (doc: add work-in-progress release-notes for 3.8.0) posted (#1) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)
Comment 2 Vijay Bellur 2016-05-16 07:21:25 EDT
COMMIT: http://review.gluster.org/14359 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 74ab2d6f10f6494785c5eeb62169317904aabc57
Author: Niels de Vos <ndevos@redhat.com>
Date:   Mon May 16 13:17:08 2016 +0200

    doc: add work-in-progress release-notes for 3.8.0
    
    Initial version of the release-notes. Follow up patches should extend
    this and make it more useful and user friendly.
    
    BUG: 1317278
    Change-Id: Ida961034e898fca6d99b5b95044be612a59c898f
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Vijay Bellur 2016-05-24 08:11:03 EDT
REVIEW: http://review.gluster.org/14518 (build: remove dht2, it is not ready for 3.8) posted (#1) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)
Comment 4 Vijay Bellur 2016-05-24 08:11:06 EDT
REVIEW: http://review.gluster.org/14519 (build: remove jbr and fdl, they is not ready for 3.8) posted (#1) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)
Comment 5 Vijay Bellur 2016-05-24 08:19:46 EDT
REVIEW: http://review.gluster.org/14519 (build: remove jbr and fdl, they is not ready for 3.8) posted (#2) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)
Comment 6 Vijay Bellur 2016-05-25 01:30:14 EDT
COMMIT: http://review.gluster.org/14518 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit c24e9997afda678a48aa6ab46c622637faeb13fe
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue May 24 13:37:20 2016 +0200

    build: remove dht2, it is not ready for 3.8
    
    Change-Id: I5663dee8da018b74e81c9fb3b618d837861ef06f
    BUG: 1317278
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/14518
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 7 Vijay Bellur 2016-05-25 06:54:09 EDT
REVIEW: http://review.gluster.org/14533 (doc: update work-in-progress release-notes for 3.8.0 RC2) posted (#1) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)
Comment 8 Vijay Bellur 2016-05-25 07:12:07 EDT
COMMIT: http://review.gluster.org/14533 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit d53bfc6f04bf7c1eaf3105e34308b2cc284ab9b8
Author: Niels de Vos <ndevos@redhat.com>
Date:   Wed May 25 12:50:44 2016 +0200

    doc: update work-in-progress release-notes for 3.8.0 RC2
    
    Added bugs addressed since RC1.
    Included a note about building from the 'make dist' tarball.
    
    BUG: 1317278
    Change-Id: Icc28f12cdbac496ac7b0bf2404ad731be98306c0
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
Comment 9 Vijay Bellur 2016-05-25 16:17:28 EDT
REVIEW: http://review.gluster.org/14537 (Added release notes for the SEEK feature) posted (#1) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 10 Vijay Bellur 2016-05-27 10:44:58 EDT
COMMIT: http://review.gluster.org/14519 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit adfaae8dcfe00187f859b8a69268c575b2d789a1
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue May 24 13:39:04 2016 +0200

    build: remove jbr and fdl, they is not ready for 3.8
    
    Change-Id: Ia24ad18c43d56a751988e562323ede26d7785848
    BUG: 1317278
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/14519
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 11 Vijay Bellur 2016-05-31 09:39:14 EDT
REVIEW: http://review.gluster.org/14569 (Added release notes for the SEEK feature) posted (#1) for review on master by Dustin Black (dblack@redhat.com)
Comment 12 Vijay Bellur 2016-05-31 09:39:18 EDT
REVIEW: http://review.gluster.org/14570 (Added release notes for Tiering aware Geo-replication) posted (#1) for review on master by Dustin Black (dblack@redhat.com)
Comment 13 Vijay Bellur 2016-05-31 09:42:51 EDT
REVIEW: http://review.gluster.org/14537 (Added release notes for the SEEK feature) posted (#2) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 14 Vijay Bellur 2016-05-31 09:42:55 EDT
REVIEW: http://review.gluster.org/14571 (Added release notes for Tiering aware Geo-replication) posted (#1) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 15 Vijay Bellur 2016-05-31 10:50:25 EDT
REVIEW: http://review.gluster.org/14569 (Added release notes for the SEEK feature) posted (#2) for review on master by Dustin Black (dblack@redhat.com)
Comment 16 Vijay Bellur 2016-05-31 10:50:29 EDT
REVIEW: http://review.gluster.org/14570 (Added release notes for Tiering aware Geo-replication) posted (#2) for review on master by Dustin Black (dblack@redhat.com)
Comment 17 Vijay Bellur 2016-05-31 15:25:57 EDT
COMMIT: http://review.gluster.org/14537 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit ffcd1e74c2ede8fedfd176b50b62a9e31ba9a08b
Author: Dustin Black <dblack@redhat.com>
Date:   Wed May 25 16:11:00 2016 -0400

    Added release notes for the SEEK feature
    
    Change-Id: I072942160533e71c57cd1632f5c7b7539751b609
    BUG: 1317278
    Signed-off-by: Dustin Black <dblack@redhat.com>
    Reviewed-on: http://review.gluster.org/14537
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 18 Vijay Bellur 2016-06-02 13:06:19 EDT
REVIEW: http://review.gluster.org/14571 (Added release notes for Tiering aware Geo-replication) posted (#2) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 19 Vijay Bellur 2016-06-02 13:06:22 EDT
REVIEW: http://review.gluster.org/14616 (Added release notes and cleaned up formatting - Mandatory lock support for Multiprotocol environment - Gluster/NFS disabled by default - Automagic unsplit-brain by [ctime|mtime|size|majority] for AFR - glusterfs-coreutils packaged for Fedora and CentOS Storage SIG - WORM, Retention and Compliance) posted (#1) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 20 Vijay Bellur 2016-06-06 12:31:28 EDT
REVIEW: http://review.gluster.org/14571 (Added release notes for Tiering aware Geo-replication) posted (#3) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 21 Vijay Bellur 2016-06-06 12:31:32 EDT
REVIEW: http://review.gluster.org/14616 (Added release notes and cleaned up formatting) posted (#2) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 22 Vijay Bellur 2016-06-07 21:37:04 EDT
COMMIT: http://review.gluster.org/14571 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 7d3cb8f729297137e5d84b28cce7507a9ca48f12
Author: Dustin Black <dblack@redhat.com>
Date:   Wed May 25 16:30:48 2016 -0400

    Added release notes for Tiering aware Geo-replication
    
    Change-Id: I0041d983aa1ff98e1e52c559af1517b17db2526b
    BUG: 1317278
    Signed-off-by: Dustin Black <dblack@redhat.com>
    Reviewed-on: http://review.gluster.org/14571
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 23 Vijay Bellur 2016-06-07 21:38:48 EDT
COMMIT: http://review.gluster.org/14616 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 5c8e4d6195ce0c7aef7aa0aff66ee8bccf30b013
Author: Dustin Black <dblack@redhat.com>
Date:   Thu Jun 2 13:00:18 2016 -0400

    Added release notes and cleaned up formatting
    
    - Mandatory lock support for Multiprotocol environment
    - Gluster/NFS disabled by default
    - Automagic unsplit-brain by [ctime|mtime|size|majority] for AFR
    - glusterfs-coreutils packaged for Fedora and CentOS Storage SIG
    - WORM, Retention and Compliance
    
    Change-Id: I17c0ac9e3c44205f657bd4445daa0c23b0fe1a82
    BUG: 1317278
    Signed-off-by: Dustin Black <dblack@redhat.com>
    Reviewed-on: http://review.gluster.org/14616
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 24 Vijay Bellur 2016-06-08 11:48:32 EDT
REVIEW: http://review.gluster.org/14675 (Added release notes for Enhance Quota enable/disable and Lock Migration) posted (#1) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 25 Vijay Bellur 2016-06-08 14:40:12 EDT
COMMIT: http://review.gluster.org/14675 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 33bd5a859e54f783d6e681cdec0157c511a90e45
Author: Dustin Black <dblack@redhat.com>
Date:   Wed Jun 8 11:46:06 2016 -0400

    Added release notes for Enhance Quota enable/disable and Lock Migration
    
    Change-Id: I540055ed6a6f4fb2eac1073d5860de11c19f075f
    BUG: 1317278
    Signed-off-by: Dustin Black <dblack@redhat.com>
    Reviewed-on: http://review.gluster.org/14675
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 26 Vijay Bellur 2016-06-14 03:25:53 EDT
REVIEW: http://review.gluster.org/14725 (Added release notes) posted (#1) for review on release-3.8 by jiffin tony Thottan (jthottan@redhat.com)
Comment 27 Vijay Bellur 2016-06-14 04:32:03 EDT
COMMIT: http://review.gluster.org/14725 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 375c82dd7b73acb57197bda5e73c075c13c78533
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Tue Jun 14 12:52:38 2016 +0530

    Added release notes
    
    - Granular Entry self-heal for AFR
    - Gdeploy packaged for Fedora and EPEL
    - Glusterfind and Bareos Integration
    - Heketi
    
    Change-Id: Ie40bf46951862ec674e5557fe3dc81b3f72abb36
    BUG: 1317278
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/14725
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 28 Vijay Bellur 2016-06-14 06:56:19 EDT
REVIEW: http://review.gluster.org/14730 (doc: finalize release-notes for 3.8.0) posted (#1) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)
Comment 29 Vijay Bellur 2016-06-14 09:54:29 EDT
REVIEW: http://review.gluster.org/14731 (Added release notes for Compound Ops & Geo-rep for Shard) posted (#1) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 30 Vijay Bellur 2016-06-14 10:26:41 EDT
COMMIT: http://review.gluster.org/14731 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 7b972c02d6fd96ef85fff4518f4122341ab5c6b0
Author: Dustin Black <dblack@redhat.com>
Date:   Tue Jun 14 09:53:31 2016 -0400

    Added release notes for Compound Ops & Geo-rep for Shard
    
    Change-Id: I4f5a92e9551d86e38512cf79dd04458806646272
    BUG: 1317278
    Signed-off-by: Dustin Black <dblack@redhat.com>
    Reviewed-on: http://review.gluster.org/14731
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 31 Vijay Bellur 2016-06-14 11:17:11 EDT
COMMIT: http://review.gluster.org/14730 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit c6d9e23b5400a34694da908b0bff768bf13fc6b9
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue Jun 14 12:54:42 2016 +0200

    doc: finalize release-notes for 3.8.0
    
    Addressed some formatting, added summary and updated the list of bugs.
    
    BUG: 1317278
    Change-Id: I6b048498cf035b98d996833debd1b0628ceee77b
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/14730
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 32 Niels de Vos 2016-06-16 12:18:09 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.