Bug 1092941 - [Doc] [RFE] Enable qemu-img to support VMDK version 3
Summary: [Doc] [RFE] Enable qemu-img to support VMDK version 3
Status: CLOSED DUPLICATE of bug 1092940
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Administration_Guide
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Laura Novich
QA Contact: ecs-bugs
URL:
Whiteboard:
Keywords: Documentation, FutureFeature
Depends On: 1007708
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-30 10:01 UTC by Laura Novich
Modified: 2016-01-27 01:59 UTC (History)
2 users (show)

(edit)
Clone Of: 1007708
(edit)
Last Closed: 2014-05-05 08:32:30 UTC


Attachments (Terms of Use)

Description Laura Novich 2014-04-30 10:01:46 UTC
+++ This bug was initially created as a clone of Bug #1007708 +++
Description of problem:
Install a image in ESXi host, export it into a VMDK format image with vSphere client(Version 5.1.0) and then copy it out in localhost. But fail to check the vmdk image info using use 'qemu-img info $image', and fail to convert the vmdk image into qcow2/raw format via qemu-img. Every time we have to use vmware-vdiskmanager to convert or check the info.

BTW, if this issue can't be fixed currently, it can be deferred to rhel6.6 or close it CANT fixed directly. But i think it's very useful for our QEMU users to implement this function.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-414.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.401.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.# qemu-img info sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk
'image' uses a vmdk feature which is not supported by this qemu version: VMDK version 3
Could not open 'sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk': Wrong medium type
2.# qemu-img convert -f vmdk sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk -O raw sluo-esx5.1-rhel6.5-x86_64-disk1.raw
'image' uses a vmdk feature which is not supported by this qemu version: VMDK version 3
Could not open 'sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk': Wrong medium type
Could not open 'sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk'

Actual results:

Expected results:

Additional info:
# qemu-img create -f vmdk sluo.vmdk 1G
Formatting 'sluo.vmdk', fmt=vmdk size=1073741824 compat6=off zeroed_grain=off 
# qemu-img info sluo.vmdk 
image: sluo.vmdk
file format: vmdk
virtual size: 1.0G (1073741824 bytes)
disk size: 12K

Comment 2 Laura Novich 2014-05-05 08:32:30 UTC

*** This bug has been marked as a duplicate of bug 1092940 ***


Note You need to log in before you can comment on or make changes to this bug.